Support » Installing WordPress » write->post, write->page empty when published

  • Hello,
    I have installed
    WP 1.5.2
    mysql 4.1.3
    php 5.0.5
    Apache 2.047 on windows XP
    I am new to PHP and mysql
    Login as admin
    I was able to connect to the database and also see the menu but when I tried to use
    write->write post or
    write->write page
    from the menu and publish there is no error shown and also no data is posted. I tried by creating a newdatabse and got the same result.

    in the index.php file of wordpress main directory I have added another line to see if I can start post on the main page and it might automatically create a generic page.

    <?php else : ?>
    <!– Ravi 10/04/05
    <h2 class=”center”>Not Found</h2>
    <p class=”center”>Sorry, but you are looking for something that isn’t here.
    <?php comments_template(); // Get wp-comments.php template ?>

    premalink was created to point to a directory like blog/generic (blog is my main wp directory) and copied the theme into that directory but still not able to post it.

    I know this is very basic but didn’t find the solution like why it is not working. Help Please.


Viewing 7 replies - 1 through 7 (of 7 total)
  • I’d would advise before adding code to the WP (so-called short and sweet) root index file and/or setting up strange permalinks try to make it work with the default setup. After that you can play around.

    Do you mean to say just after mysql/php/wordpress is installed when I go through wp-admin/index.php and use the write->write post it should work? I tried multiple times by even reinstalling the whole thing.

    Now I tried by creating a second database/instance on the same mysql installation and created a new directory with fresh wp root directory but it didn’t work. Same results no error and no data and nothing in the database wp_posts table.
    So I tried to create the page and that will work as root node with a page and it did not work and then I tried to see if I can atleast see the comment box to post it by just using one line code and unfortunately it did not.

    I thought this is 5min installation and reinstalled many times but some how cannot get pass through this step of simple posting.

    Is the below error normal while installing. May be this explains.

    WordPress database error: [Field ‘link_notes’ doesn’t have a default value]
    INSERT INTO wp_links (link_url, link_name, link_category, link_rss) VALUES (‘’, ‘Carthik’, 1, ‘’);

    WordPress database error: [Field ‘link_notes’ doesn’t have a default value]
    INSERT INTO wp_links (link_url, link_name, link_category, link_rss) VALUES (‘’, ‘Donncha’, 1, ‘’);

    and may more like the statements above

    I was able to insert a row into wp_posts directly from mysql prompt but when used through admin write-> write post nothing is inserted into the database and no error shows after the save and it come back with new page to post again.

    Any help please?

    Note: I have not modified any code so far and that is the result.

    After Installation! does write-> write post work straigt out of the box. And while installing do you get the Database error! not sure why I get those errors.

    From the error insert statement above Field ‘link_notes’ shows that column value is not inserted! very strange as it works for everyone.

    I was able to insert into table manually and when views through the webserver I can see what I inserted(Db connect is fine).

    Even then I am not able to get the post box on my main page either by default or by adding the comments_template and may be because I am not even able to use the write->write posts event to successfully store the data and retrieve later (NO error after filling in the data it just blanks out to new one and nothing in the mysql db).

    Any help is much appreciated.

    I’m facing the same problem on WP 1.5.2, mysql 4.1.3, php 5.0.2, Apache 2.047 on windows XP sp2.
    Have you resolved this?

    I fixed the problem. I switched my XAMPP bundle from Apache2Triad Edge (1.5.3) to Stable (1.4.3). This has Apache2.0 PHP4 MySQL4 instead of Apache2.1 PHP5 MySQL5.

    My WP install is working out of the box now. I’m not sure why WP chokes on PHP5 MySQL5 – probably should be on the dev team’s radar…

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘write->post, write->page empty when published’ is closed to new replies.