Support » Plugin: My Movie Database » wrapper is disabled in the server

  • Hello, after installing the plugin, the following error messages appeared in the ‘movie’ field when adding new movie.

    Can you help me solve it?

    Thank you

    
    Warning: file_get_contents(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/storage/4/99/f3/meusite/public_html/meusite/wp-content/plugins/my-movie-database/core/TemplateFiles.php on line 194
    
    Warning: file_get_contents(http://meusite.hospedagemdesites.ws/meusite/wp-content/plugins/my-movie-database/mmdb_templates/settings/componentsToLoad/components-movie.json): failed to open stream: no suitable wrapper could be found in /home/storage/4/99/f3/meusite/public_html/meusite/wp-content/plugins/my-movie-database/core/TemplateFiles.php on line 194
    Search Database
    
    Warning: file_get_contents(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/storage/4/99/f3/meusite/public_html/meusite/wp-content/plugins/my-movie-database/core/TemplateFiles.php on line 194
    
    Warning: file_get_contents(http://meusite.hospedagemdesites.ws/meusite/wp-content/plugins/my-movie-database/mmdb_templates/settings/i18nForJavascript/jsI18n-movie.json): failed to open stream: no suitable wrapper could be found in /home/storage/4/99/f3/meusite/public_html/meusite/wp-content/plugins/my-movie-database/core/TemplateFiles.php on line 194
    
    • This topic was modified 1 year, 3 months ago by Yui.
    • This topic was modified 1 year, 3 months ago by Yui. Reason: please use CODE button for code formatting
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Kostas Stathakos

    (@djleven)

    Sorry for the late response.

    This is a server issue not allowing allow_url_fopen. If you have control of the server you can change the php.ini setting to allow this. But if you are on a shared hosting server, things are not so simple.

    I have bumped this to top priority, it will be fixed in the new version. It is wrong for the plugin to depend on this server setting. This code was supposed to have been changed but I never did get to it.

    Thanks for your feedback.

    Thread Starter Wanderley Garcia

    (@wanderleygarcia)

    Thanks for the answer.

    There is some forecast as to when this fix may be available.

    I use shared hosting server.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘wrapper is disabled in the server’ is closed to new replies.