Support » Themes and Templates » WPZOOM Academica Homepage Slideshow question

  • Hi,
    I’m using the WPZOOM Academica theme. It seems that the online documentation on how to use the Homepage slideshow doesn’t reflect what that theme configuration pages show. I am using the latest version of the theme, version 1.2.

    Any suggestions?

    Its not clear how I should set the custom field, wpzoom_slide_url. Does it expect a URL or path to an image or a page?

    What goes in the slide link field? What’s the syntax?

    All I want to do is to add a slide show of many 2-3 slides (images) to the top of the home page.

    Thanks in advance,
    Steve

Viewing 15 replies - 1 through 15 (of 45 total)
  • srsars

    (@srsars)

    Did you ever figure it out cuz i’m having issues with it too.

    mattb3476

    (@mattb3476)

    I had the problem / confusion saz25 first mentioned. I posted in the WPZOOM help forums and a moderator, Dumitru, helped me resolve the issue.

    WPZOOM help forums: http://www.wpzoom.com/forum/index.php

    I would recommend anyone with the theme go there, because I included pictures in my post.

    The post:
    http://www.wpzoom.com/forum/viewtopic.php?f=133&t=6107&p=24673#p24673

    But, here’s some info.

    ***ME***

    I am having the same problem with the Academica slideshow as this guy, as well as others that I have read on the WordPress forums.

    After a fresh install of both WordPress and Academica, I cannot get the slider to work. I have followed the minimal documentation, but with no success.

    Others with the problem: http://wordpress.org/search/academica?forums=1

    Error given when I try to click to “view” a slide from the Slideshow slide list:

    “Catchable fatal error: Object of class WP_Error could not be converted to string in /home/content/09/8614809/html/wp-content/themes/academica/functions/wpzoom-functions.php on line 328”

    Site URL: Only an “in construction” page is up currently, which displays on an alternate theme. I am using the Theme Test Drive plugin while I set up Academica. I have troubleshot my problems without the plugin enabled and all issues were the same. This is a hired job, and I cannot have a development site public.

    Theme Test Drive: http://wordpress.org/extend/plugins/theme-test-drive

    WordPress version: 3.2.1

    Theme Versions: Academica 1.2

    Here’s what I did.

    I enabled the slideshow and selected for two frames.

    Image

    I added two slides.

    Image

    But when I click to view the slide, I get the error given above.

    Image

    And when I look at the source code for my homepage, there is nothing for a slideshow.

    And, fyi, the documentation for the slideshow seems inaccurate.

    Here’s a screen grab.

    Image

    This is what I have.

    Image

    For the slide options, there is only a box for a “slide link.” No “Slide Type” drop box or anything else.

    ====================

    ***MODERATOR***

    Open /functions/wpzoom-functions.php and find these lines (#328):

    Code:
    echo get_category_parents($cat, TRUE, ‘ ‘ . $delimiter . ‘ ‘);

    Replace with:

    Code:
    if ($cat) {
    echo get_category_parents($cat, TRUE, ‘ ‘ . $delimiter . ‘ ‘);
    }

    See if this helped.

    ====================

    ***ME***

    Thanks again for the speedy reply, Dumitru!

    I replaced the line you said. Now, when I click “View Slideshow Item,”

    Image

    a page comes up, but the slide image is not displayed.

    Image

    I have checked the link in the “Slide Options” “Slide Link” box, and it is correct. For kicks, I also am using an image with the same dimensions as the slideshow on the Academica Live Demo – in case it needs to be exact.

    Also, I don’t see anything in my homepage source code for the slideshow.

    In the WPZOOM Live Demo, it follows the closing of the header div.

    Image

    There’s nothing in mine.

    Image

    ====================

    ***ME***

    I got the slideshow wrapper to show up on my homepage. But, the images aren’t there yet.

    In the “Reading” settings of the WordPress “Settings” bar, the “Front page displays” setting needs to be set to “your latest posts.” If it is set to a static page, the slideshow container doesn’t show up.

    Image

    Image

    I had set it to my “homepage” page, since I want a static page as my homepage, rather than posts.

    But, it looks like you need to do this only in the WPZOOM “Theme Options.”

    Image

    ====================

    ***MODERATOR***

    When you create a slideshow item and set a featured image for it, it isn’t shown on the page for the slideshow item (when you open it).

    You still have to insert it into the content body for the custom post, we don’t enforce it to be displayed, as many customers prefer to keep it just on the homepage.

    If you don’t provide a link to your website, we can’t help much.

    ====================

    ***ME***

    Thank you for your help, Dumitru. I’m all set up!

    I am a videographer building a small business website. I am a competent hobbyist with web design and WordPress, but by no means is it my territory.

    For those having who have trouble with the same things I did, here’s a little more information. It’s embarrassing, but I’ll admit that it confused me!

    When setting up a slideshow,

    Image

    the “Slide Link” in the “Slide Options” panel is what the slide links to when it’s clicked. It’s NOT a link to the slide to be included in the slideshow.

    Image

    Each slide is created by making separate slides with “Add a New Slide”

    Image

    and uploaded through the featured image panel in the “Edit Slideshow Item” page.

    Image

    If it uploads correctly, you’ll see it in the content display of the page.

    Image

    I think the confusion for me came from the documentation, which did not mention the “Featured Image” panel and made it seem like all the slide information was contained in the “Slide Options” panel.

    Image

    Adding to the confusion is that the “Slide Options” panel in the documentation is for a video and includes an interface that does not resemble the one in the template.

    Thank you this did it for my site!

    Just when I was going to scrap the theme.

    Could you elaborate and explain each step in more detail?

    I created 4 slides using “Add a New Slide”, for each slide I named them Slide 1, Slide 2, Slide 3 and Slide 4. I was told that titles are important, otherwise it won’t work.

    Next for each slide I’ve created, I click on “Set feature image” and select one image file under “Media Library” (by clicking on “Show” for that particular image file of interest). Then keeping all the options at their default state, I select the “Use as featured image”.

    After that I’m stuck, what should I do next? Did I missed out any important step?

    Do I need to attach the image files to their respective slides?

    Any assistance would be greatly appreciated.

    Everything I learned is laid out as best I could in the WPZOOM support forums.

    Work through the stuff in this help thread (there’s pictures!):

    http://www.wpzoom.com/forum/viewtopic.php?f=133&t=6107&p=24673&sid=1c2e08d0bdc085b522df3c0c81f27c74

    You’ll need to sign up first.

    Matt, you already helped me a lot, thank you. But like Onyx, I’m still stuck. What I did:

    – Checked if WP “Reading” settings “Front page displays” is set to “your latest post”
    – Enabled Slideshow in WPZOOM settings “Homepage Options” & set a static page
    – Added “New Slides” (Titles: “Slide One”, “Slide Two” etc.), set a “Featured Image” for each, and published them

    What happens is:
    – Source code looks absolutely correct (like in the demo)
    – Image links, checked directly from source code, are fine
    – The Slide Wrapper shows up on the Home Page exactly as it should
    – The Images DON’T appear on the Home Page

    If I missed something obvious, please feel free to amend/correct.

    Also, I followed your advice and signed up to the WPZOOM support forums—but as I’m not a paying member, it turns out, I don’t have access to any of the threads you linked to. And while so many people have problems to get this slider to work, which really IS a defining feature for this theme, and the “documentation” not only skirts the issue but actively confuses it, I’m getting a little suspicious here that this whole thing might just be an elaborate honey pot. (I don’t mind paying for a theme, I actually would have bought Academica if it weren’t free, but this annoys me to no end.)

    They seemed to have changed the theme, making simplifying it, but it does not work. All you are supposed is, “Set the absolute path to an image, will be used in the slider.” I did that and nothing happens on the home page. And if you want to go on the forums you have to pay around $200 to sign up. I would happily have bought this for $50. But I am not willing to pay $200 plus a monthly fee.

    Anyone have any idea what is wrong with the new version? I am sure these is some kind of code error. But if it did work this theme would be very easy to use. Additionally any idea of the size of image you are supposed to use in this theme?

    That “size of image” might actually relate to the problem.

    Whatever size you use, the images are resized via the timthumb script to 960×300 px (plus a bunch of slices for the transitions). And I suspect that it is here where generating the images fails.

    If you have a regular WP install, you’ll find the timthumb script at this location:
    /wp-content/themes/academica/scripts/

    What I did so far:
    – checked the folder and script permissions (set to 755)
    – checked if the PHP GD library is active on the server (it is)

    So everything looks okay, but I still suspect it’s got something to do with timthumb.
    Suggestions welcome.

    I figured out what the problem was, somehow I got version 1.0.2 and the current version is 1.2.0. I got the new version and did what is said above. The other problem is that in the setting/reading, you have to make sure that “Front page displays” is set to recent posts.

    Wish it was that easy… I’ve got version 1.2.2 (I checked) and it still doesn’t work. (And yes, my “front page displays” setting is set to “your latest posts.”)

    Did you ad the code snippet form above? I did that too and made 5 slides and named them Slide-1, Slide-2 etc and made sure the page names where the same.

    I had 2.2 also.

    I also changed some of the folder permissions in the theme 777 as that will sometimes stops wp-press from being able to auto generate scripts. I had that happen with another theme from this company.

    The file permissions might do the trick for you.

    Yes, I added the snippet (but it actually fixes a different problem).

    I also made 5 slides, and I named them exactly like you did, and the pages ditto. I also set theme folder permissions to 777 (and tried 755 for good measure, in case the server has a safety-catch for 777 permissions).

    Still zippo.

    Also, I keep wondering about timthumb. Usually, it needs a cache and a temp folder to work properly and generate the images, and usually they’re in the same directory as the script. But there aren’t any in the script folder. (I created them both there w/ 777 permissions, but to no avail.) Does anyone know where the timthumb cache/temp folders are for the Academica theme?

    Anyways, I gotta go to bed now (it’s almost 6 a.m. around here). I’ll be back to work on this problem tomorrow.

    I made any folder that had any possibility of running the script 777, from the JS folder and each folder in it to the scripts folder. Not sure what else you could do.

    For me the thing that was stopping it was the weird way you have to set it up where the theme controls the home page and not word press.

    I have:

    “Show slideshow on homepage?” Yes
    “Homepage Slideshow Items” 5
    “Show static page on homepage?” Yes
    “Page to be displayed on homepage” “the name of the page”

    Then the WEB reading setting is set to:

    “Your latest posts”

    I have the SEO turned off as I use Yeost SEO.

    And I have the Navigation fully set up.

    Not sure if any of that will help, but the theme may be cause a conflict with a plug-in or something as well.

Viewing 15 replies - 1 through 15 (of 45 total)
  • The topic ‘WPZOOM Academica Homepage Slideshow question’ is closed to new replies.