Support » Plugin: WPtouch » WPTouch W3 Total Cache – must disable browser caching?

  • OK, I feel like I must be missing something obvious, but I’ve reached my frustration point. I’m bringing my blog back from a long hiatus, and to prepare for that I’m updating it with the latest and greatest. That includes upgrading to WP3.1.3, changing themes, replacing WP Super Cache with W3 Total Cache and installing WPTouch.

    It has been going fairly smoothly, except I’m having an issue with WPTouch which I think is tied to W3 Total Cache, but I’m not positive. I’ve searched for threads on working with these two and I found http://nimopress.com/pressed/blog-building-how-to-configure-w3-total-cache-to-work-with-wptouch-for-wordpress/ as well.

    I started off with a stock install of both, and things seemed to be OK. Testing from a Motorola Droid I’d see the WPTouch version of the site, and my desktop got the ‘normal’ version. But if I tried to use the On/Off toggle on the WPTouch page it’d just reload the page in the same version – and the toggle was the same. But if I follow a link the next page loads the ‘correct’ theme. So say I load the home page and get the WPTouch version, I hit the toggle and still see that. But then I follow a link to a post and see the ‘desktop’ version and the toggle is now ‘Off’.

    So it looks like the request is making it to the server and being registered, but the browser is reloading the same page and only new pages are getting the change. But then those pages are ‘stuck’ on that theme. This does seem like a caching issue.

    Based on what I found in past threads I added this list to the Rejected User Agents on the three W3 Total Cache pages:
    acer\ s100
    android
    archos5
    bada
    blackberry9500
    blackberry9530
    blackberry9550
    blackberry\ 9800
    cupcake
    docomo\ ht\-03a
    dream
    googlebot-mobile
    htc\ hero
    htc\ magic
    htc_dream
    htc_magic
    incognito
    ipad
    iphone
    ipod
    kindle
    lg\-gw620
    liquid\ build
    maemo
    mot\-mb200
    mot\-mb300
    nexus\ one
    opera\ mini
    samsung\-s8000
    series60.*webkit
    series60/5\.0
    sonyericssone10
    sonyericssonu20
    sonyericssonx10
    t\-mobile\ mytouch\ 3g
    t\-mobile\ opal
    tattoo
    webmate
    webos
    240×320
    2\.0\ mmp
    \bppc\b
    alcatel
    amoi
    asus
    au\-mic
    audiovox
    avantgo
    benq
    bird
    blackberry
    blazer
    cdm
    cellphone
    danger
    ddipocket
    docomo
    dopod
    elaine/3\.0
    ericsson
    eudoraweb
    fly
    haier
    hiptop
    hp\.ipaq
    htc
    huawei
    i\-mobile
    iemobile
    j\-phone
    kddi
    konka
    kwc
    kyocera/wx310k
    lenovo
    lg
    lg/u990
    lge\ vx
    midp
    midp\-2\.0
    mmef20
    mmp
    mobilephone
    mot\-v
    motorola
    netfront
    newgen
    newt
    nintendo\ ds
    nintendo\ wii
    nitro
    nokia
    novarra
    o2
    openweb
    opera\ mobi
    opera\.mobi
    palm
    panasonic
    pantech
    pdxgw
    pg
    philips
    phone
    playstation\ portable
    portalmmm
    proxinet
    psp
    qtek
    sagem
    samsung
    sanyo
    sch
    sec
    sendo
    sgh
    sharp
    sharp\-tq\-gx10
    small
    smartphone
    softbank
    sonyericsson
    sph
    symbian
    symbian\ os
    symbianos
    toshiba
    treo
    ts21i\-10
    up\.browser
    up\.link
    uts
    vertu
    vodafone
    wap
    willcome
    windows\ ce
    windows\.ce
    winwap
    xda
    zte

    I deployed and cleared all of the cache, but it doesn’t seem to have made any difference. If I deactivate W3 Total Cache, WPTouch seems to behave correctly. Doing more debugging I determined that the issue is browser caching. If I disable browser caching in W3 Total Cache then, even with it enabled in general, it seems that WPTouch works as expected.

    Before I spent too much time possibly re-inventing the wheel, I wanted to see if anyone else has W3 Total Cache working with WPTouch *with* browser caching enabled. If so, did you have to do anything special?

    The site is http://www.gizmolovers.com/ Ignore the style, I’m still working on re-customizing the theme since I just switched from an ancient custom template I’d been using. So it is pretty much stock ‘twentyten’ right now.

    Right now it is running *with* the Rejected User Agents list and with browser caching disabled. (I plan to test it without the list too, but I need a break.)

    Thanks.

Viewing 15 replies - 16 through 30 (of 30 total)
  • Giving it some thought.

    You’ll have to switch to anything other than disk enhanced mode and add some query string pattern in the reject URIs field on the page cache settings tab.

    @frederick – can you say more? I don’t see that screen. Plus, perhaps an example if you have a moment?

    derickschaefer – thanks for the list of Rejected User Agents. I have applied to all three areas. Even with browser caching enabled, it seems to be working at least on desktop and mobile without swapping pages between the two. However, in order for all to work without hanging up, I’ve had to disable minify caching.

    Looking forward to added feedback by the community on these two plugins and compatibility. I realize that this is fairly complex.

    This issue is still happening Frederick. When going to view the site on my Android or Safari Dev User AGent iPhone; it renders the previous page. Once I refresh/reload the page, it renders the correct mobile format.

    It does the same thing the other way. When viewing on my Google Chrome and if I viewed it on my mobile on WPTouch PRO, it renders the WPTouch PRO page on my desktop browser. A simple reload fixes it to render the right page.

    Please advise. I can give you complete access.

    Email me at rasolis <at> readipress dot.com (formerly Webshoo.com).

    Thanks,
    Anthony

    I noticed that the version of jQuery in WordPress is not up to date. You can try updating it by replacing /wp-includes/js/jquery/jquery.js with the updated version which you can download from here http://blog.jquery.com/2011/09/12/jquery-1-6-4-released/.

    This, coupled with the list of Rejected User Agents, seems to have cleared the issue for me.

    should we delete the lists on User Agents Group on W3 Total Cache settings page? I mean, there are 2 groups, High and Low, which contains the list of user agents group..

    Plugin Author BraveNewCode Inc.

    (@bravenewcode)

    pythonskynet,

    You shouldn’t need to remove those. You only need to add WPtouch’s default mobile user agent list to the ‘Rejected User Agents’ area for the types of caching you have enabled – Page Cache/Minify/CDN.

    I’ve noticed this problem too. It’s particularly annoying for those of us without a plethora of mobile devices to test on, and it’s way too complex for novices to get right first go. It would be great if this could be made to work correctly out of the box when W3 Total Cache and WP Touch are used together.

    Cheers,
    Graham

    You can always disable the user agent groups completely.

    Boy, a long post on a very irritating problem.

    Well MegaZone, I had the same issues you did and for a while had no mobile plugin. Then I reinstall WPTouch only to have the same strange problem again.

    Like you already did I too discovered that WPTouch and W3T aren’t fully compatible, even though no errors exist.

    I did discover something else though.

    When I entered my list of Rejects (copied here, if that’s ok?) and inserted them in only the page cache and the minify, my WPTouch works time and again without the need for hacks and with browser caching active.

    However, and this is a big one, I have CDN DISABLED!.

    When I enable that feature I am back to square one.

    So… since I seem to be having good speed thus far I’ve decided to forsake CDN for now and thus far WPTouch is working like a charm with browser cache enabled and the rejection agents list filled out.

    Hope that helps a bit?

    Lode

    @ndjworldnews, can you submit a bug submission form from the support tab of the plugin?

    Hello Frederick;

    Would love to but can’t find a ‘support’ tab.

    Where should I be looking for that?

    Lode

    In the performance menu.

    Wonder why this issue isn’t fixed as yet? Any progress with the support tickets filed by people above?

Viewing 15 replies - 16 through 30 (of 30 total)
  • The topic ‘WPTouch W3 Total Cache – must disable browser caching?’ is closed to new replies.