Support » Plugin: WPtouch » WPTouch not applying mobile theme to every page

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Dale Mugford

    (@dalemugford)

    This is usually because you’re running a cache plugin. Are you running WP Super Cache or something similar?

    I have the same problem. 75% of my posts/pages look great on mobile phone – the rest not. I am running WP Super Cache. If that is the problem, should I just deactivate it?

    Go to WP Super Cache Settings > Plugins > WPTouch > select Enabled.

    Thank you for your suggestion.

    I should have mentioned in my post above that I had already enabled WPTouch. So even with WPTouch enabled, I have the above problem.

    Any other ideas?

    Oddly enough I did not have this enabled in WP Super Cache but the website seemed to look “OK” (some text out of place etc.) I just enabled the plugin in WP Super Cache – maybe this will fix a couple of the formatting issues.

    Plugin Author BraveNewCode Inc.

    (@bravenewcode)

    If you are running any sort of caching plugin or service, you’ll want to configure it not to cache mobile pages nor to serve cached pages when mobile devices are detected. To do so, enter the user agents found under Advanced Options > Custom User-Agents to the “rejected user agents” areas in your caching plugin’s settings. Remember to clear your plugin, browser, and device caches before retesting.

    If your desktop theme uses custom post types, custom page templates, or any other advanced functionality to display content on the posts/pages mentioned, the free version of WPtouch does not offer the capability to transfer those features to your mobile theme. WPtouch Pro is built to accommodate advanced desktop theme functionality such as custom post types, custom page templates, and shortcodes.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘WPTouch not applying mobile theme to every page’ is closed to new replies.