WPtouch Mobile Plugin
wptouch login not working (9 posts)

  1. rohonupe99
    Posted 2 years ago #

    I am using wptouch on a website that is installed on localhost xampp server. The site is installed in a sub directory of my web server. my website is bamasocialnetwork.com and you can login with the username wordpress and password 123456 to test wptouch. The problem I am getting is when a user tries to login, an object not found page shows up. The url of that page is in the path c:/xampp/htdocs/wp-login.php, which is a page that does not exist. my website directory is NOT installed in the root of my web server, but within a sub directory. Instead of it being in c:/xampp, it's in c:/xampp/htdocs/bamasocial/. So it appears that when I try to logn with wptouch, that it resolves to the page c:/xampp/htdocs/wp-login.php, which does not exist, instead of c:/xampp/htdocs/bamasocial/wp-login.php which does exist. so how can I fix this?


  2. rohonupe99
    Posted 2 years ago #

    try logging in with username testuser and test123 password

  3. BraveNewCode Inc.
    Plugin Author

    Posted 2 years ago #

    We were able to login with the login credentials you provided. Here's a screenshot for reference - https://dl.dropbox.com/u/19501220/ios-s-3.png

    You can deactivate the test login now if you'd like.

  4. amcclay
    Posted 2 years ago #

    I'm having a near identical problem. When logging in from wptouch, I immediately get a 404 error.

    It's the same issue When entering the login credentials, I immediately get redirected to the wrong page for some reason.

    My site is also contained in a subdirectory

    So, it's like this:

    - Login to my site at http://www.mysite.com/subdir

    - Wptouch version of site shows properly

    - Login from wptouch using login tab from menu button

    - enter credentials

    - Immediate 404 from sending me to http://www.mysite.com/wp-login.php (which doesn't exist as my WP install is in the subdirectory 'subdir')

    So, it's obviously ignoring the subdirectory path for some reason.

    Any idea how to fix this?

  5. narayanan1
    Posted 2 years ago #

    Hello - we are having the exact same problem - how did this get resolved ?

    Thanks for the guidance.

  6. BraveNewCode Inc.
    Plugin Author

    Posted 2 years ago #

    It sounds as if there may be conflicts present in your WordPress configuration contributing to the issues you're reporting.

    To isolate which plugin(s) may be contributing to the trouble, deactivate all except WPtouch from within the WordPress Plugins area, clear your browser cache and local data then test.

    If WPtouch functions well, you may then enable the rest of your plugins one at a time, repeating the process, until you can identify which is/are causing the problem.

  7. amcclay
    Posted 2 years ago #

    I actually just rolled back to 1.4, which worked fine for posting.

    With the latest version of WP, the first thing I did (of course) was disable all other plug-ins and this issue still occured.

    Is it possible having a plug-in (even if deactivated) could be causing this issue?

    The consistent factor here seems to be WP installs in a subdirectory. It seems that parts of WPTouch are ignoring the subdirectory path and calling for php code in the site root for some reason.

  8. narayanan1
    Posted 2 years ago #

    I tried with plugins disabled, and the problem does not go away.

    @amcclay - you are absolutely right. I can see from url that parts of WPTouch are ignoring the subdirectory path if WP is installed in a subdirectory.

    @bravenewcode - appreciate if you guys can you please help solve this?


  9. patrickbrazil
    Posted 1 year ago #

    I have enabled the fly-in login option on wptouch, but I do not see any difference on the web app? Do I have to perform any additional task to create a login page? Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WPtouch Mobile Plugin
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic