Support » Plugins » WPTOUCH doesnt work for me…

  • Hi all,

    i just installed wptouch but doesnt work when i check on my samsung nexus S… looks like its not finished version… white background and a feed of articles but i don’t think its a good looking… I didn’t find anithing about that…

    Is the last version of wptouch is OK with latest version of wordpress ?

    Thanks a lot for your answers !


Viewing 14 replies - 1 through 14 (of 14 total)
  • Your desktop theme may use functions that are incompatible with the free version of WPtouch such as custom post types, custom page templates, or shortcodes.

    If not, try testing for plugin conflicts by temporarily deactivating all other plugins, clearing all caches, then checking your site.

    Lastly, you might want to test your site on a different device or in a desktop browser using a user agent switcher to check for device-compatibility issues.

    I have changed nothing on my site, nor did I upgrade any plugins…including wptouch. I was on 1.4.2. I have since tried updating WordPress and wptouch to remedy the situation. Didn’t help. I know it works because it WAS working. I have tried disabling all other plugins and even resorted to temporarily activating the default theme in WordPress and just the wptouch plugin. Doesn’t fix it. On my Samsung Nexus S….Googles best phone…wptouch blows… all I see is some blue feed links with white background.

    Great troubleshooting info. Thank you. From this site:,the user agent string for your device is ‘2.3 Nexus S—Mozilla/5.0 (Linux; U; Android 2.3; xx-xx; Nexus S Build/GRH41B) AppleWebKit/533.1 (KHTML, like Gecko) Version/4.0 Mobile Safari/533.1’

    What happens when you clear your device’s cache and enter ‘533.1’ or ‘GRH41B’ in the Custom User Agent field in WPtouch?

    I tried that, and it didn’t do any good…so I looked up what my phone was passing as a User Agent and here it is:

    My User Agent: Mozilla/5.0 (Linux; U; Android 4.1.1; en-us; Nexus S Build/JRO03L; CyanogenMod-10) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Mobile Safari/534.30

    I then added JRO03L and 534.30 to Custom User Agents in wptouch control panel and it didn’t change anything. It’s still trying to load the wptouch, but it doesn’t do so successfully. It is just links with a white background. If I change what page loads in the control panel on wptouch within WordPress, it shows an icon with no information other than “Front Page” (which is the name of the page I set it to in the control panel)

    Any other ideas?

    Please post a url so we may have a look.

    I am having the exact same issue on my site. I’ve done a temporary fix by clicking “display full site to first time visitors” which at least gives me the menu functionality back on my Nexus S phone which is running the latest android operating system. Mobile version looks fine/useable on my Nook Color tablet. I added the Nexus and Galaxy agents to the custom agents field.

    When I don’t have “display full site to first time visitors” clicked, I have the exact same issue as Mattoid above–white background w/ icon with “Home” and no functionality/menu/clickability.

    If I could be sure that upgrading to Pro would solve the issue w/ android compatibility, I’d be willing to do it as I’d like to tinker with the look a bit beyond what the free version is letting me do (only have grey background versions is depressing as is having the page titles displayed :))


    (Oh and I should add that my “Fix” only works the first time the site is loaded on my phone–I figure it will help somewhat with first time visitors until a permanent fix is found)

    Hello Annabeth. I don’t see WPtouch active in the source of your site and cannot comment as to its functionality at this time. However, if your desktop theme uses any of the advanced functionalities listed above, you may experience issues with the free version of WPtouch as it simply is not built to accommodate those sorts of features.

    My website is:

    If this can get resolved, for your trouble, I will commit to buying a professional license.

    Does the WP-Touch auto-load on desktops? I don’t see it in my source code either (when viewing the source from a desktop). But it obviously works for me on other mobile devices.

    Thank you for the url. Here are screenshots of your site on an Android device where we see WPtouch functioning as expected:

    Yours may be a device-specific issue as above. Have you tried clearing your device’s cache?

    And here is what it looks like from the Nexus S:

    Thank you for the screenshot. What we’re seeing there is the raw feed as returned by your RSS link in your menu. That will be a page (and by that I do not mean a WordPress “page”) that is outside of your website and, therefore, not displayed by WPtouch.

    Sigh. On my Nexus S in JB 4.1.2 it just doesn’t load correctly with stock browserw. It looks just fine on Chrome which I downloaded from the Google Play store. Obviously this must not work right with new Android OS.

    This thread is exactly my issue:

    So I’m not the only one having this problem. If WP Touch Pro fixed it…and I knew this for sure, I’d upgrade.

    Brave New Code…do you have a trial version or be willing to let me test this for you on the Pro to reach conclusion definitively instead of wasting your developer time? More Android devices are going to Jelly Bean so I’d imagine you would want this resolved soon!

    As noted, the feed display is handled outside of WPtouch (and will also be outside WPtouch Pro) because the feed url is not a page within your website.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘WPTOUCH doesnt work for me…’ is closed to new replies.