Support » Plugins » WPPM with CURL

  • I modified WPPM version 1.7.0 b to work with CURL on sites where allow_url_fopen was disabled.

    You can find the plugin here

    Everything remains the same, and the change over to using CURL should be entirely transparent to the user.


Viewing 6 replies - 1 through 6 (of 6 total)
  • Howdy. I installed this as directed (I think) but I am getting this:

    Warning: fopen(wp-content/plugin_manager/params): failed to open stream: Permission denied in / on line 1271

    The line in question (1271), in wp-plugin-mgr.php, reads like this:

    if ($file = fopen ($location, "w"))

    No idea what could be “wrong” with that line; it’s the default file I downloaded. Thus it must be something about the way my stuff is setup or something about the way things are interacting. This is where I get lost.

    Other facts: The error occurs at launch of WPPM 1.7 itself (“click here”) from within admin area, under plugins. I assume WPPM should be “activated” there as well, but have tried it both ways, with the same error result. I do get the screenfull of plugin listings, but the error message is in there as well.

    My host has NOT turned off ‘allow_url_fopen’.

    I’m using the “temporary” option on the configuration screen.

    No other permissions problems at this time. Just the one error (above).

    I’ve tried changing from ‘use CURL’ to ‘don’t use CURL’ (line 23 modification, as instructed) and I get same error.

    I have not tried to install any plugin(s) using the one-click feature yet.

    I’ve never used any version of WPPM before. This is my first attempt to install it.

    Don’t know if this is relevant, but I did change something a while back so my admin emails would not come from “Nobody” on my most excellent host’s Apache server. It was some easy piece of code found here somewhere. Sorry I don’t recall what/where more specifically.

    Thanks in advance for any clues.

    The only modification that I made was to change the use of FOPEN to CURL for remote files, all local files are read/written to using FOPEN.

    Now in this case it looks like you have a directory permission issues, and I think it’s related to the change you made in regards to the user.

    Take a look at /wp-content/plugin_mgr and see which user “owns” that directory.

    Once quick fix is to set the permissions of that particular directory to 777 through your FTP client.


    Wow, thanks for the fast reply. 🙂

    I just checked the folder called “wp-content/plugin_manager” (assumed that was the one you meant?) and the permissions are 755. For the entire folder.

    Are you saying I should have that be 777 instead? And leave it that way, forever? Is that safe, from a security standpoint? Sorry I don’t understand all this. I think I’m VERY close to having it all work, just that ONE little error line! Frustrating.

    Thanks again!

    Tried changing the permissions to 777 for the entire wp-content/plugin_manager directory. Still getting the same error when I log in with my FTP name and PW, after pressing the “temporary” button.

    The “owner” of the directory is me. Which is correct, right? The image files for the plugin belong to “99.”

    (“If you choose ‘temporary’, permissions will be restored between each use and you will be prompted for your ftp password each time you want to perform a one-click install.” This is the one I want to use.)

    Would anyone else have a solution for this (as explained in my first post, above)? Thx.

    Nevermind! 🙂 Aborted.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘WPPM with CURL’ is closed to new replies.