Support » Plugin: WP Photo Album Plus » wppa-non-admin.php error on front-end pages (above header)

  • Resolved kidznc

    (@wsp-kk)


    FYI – I just installed the plugin on a site that I’m working on offline, and found this PHP error showing above the header on all the front-end pages:

    Warning: fopen(D:/xampp/htdocs/knc2015/wp-content/uploads/wppa/temp/wppa.::1.js): failed to open stream: No such file or directory in D:\xampp\htdocs\knc2015\wp-content\plugins\wp-photo-album-plus\wppa-non-admin.php on line 261
    
    Warning: fclose() expects parameter 1 to be resource, boolean given in D:\xampp\htdocs\knc2015\wp-content\plugins\wp-photo-album-plus\wppa-non-admin.php on line 270
    

    Not sure if this is a WP 4.9 conflict or not.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Jacob N. Breetvelt

    (@opajaap)

    This means that your $_SERVER['REMOTE_ADDR'] is corrupt; it contains ::1 instead of a proper ip address, most likely because you are running on a local host.

    To avoid this, UNtick Table IV-A13: Defer javascript.

    BTW: It is NOT a good idea to defer javascript when wppa is installed, unless you want to see: Proudly powered by Worpress at the bottom of the page BEFORE the photos….

    However, this will be fixed in the next version (6.7.07)

    Thread Starter kidznc

    (@wsp-kk)

    The site is a local installation on XAMPP, indeed, this fixed the problem.

    Thank you!

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Fixed 6.6.07

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘wppa-non-admin.php error on front-end pages (above header)’ is closed to new replies.