Support » Networking WordPress » wpmu_create_blog bug?

  • hagu81

    (@hagu81)


    Hello

    I try to use the function wpmu_create_blog multiple times in a script.

    When i run the script, it creates only one blog, the other ones are ignored.

    Is this a bug?

    I use WordPress 3.0

Viewing 4 replies - 1 through 4 (of 4 total)
  • hagu81

    (@hagu81)

    There was a little misstake in my script. But a problem is still there.
    When i try to create multiple blogs in one script, the first blog is being created.
    But on all other blogs it doesn’t create an option table, comment table, links table, postmeta table, posts table, etc.
    All blogs are in the ‘wp_blogs’ table.

    Is there an other way to add multiple blogs with one script? The XML-RPC does not allow to create a blog.

    Thanks for your Help

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    That function has historically had issues misfiring. Take a look at how other plugins (like this one) have handled it.

    hagu81

    (@hagu81)

    I habe found this solution

    http://core.trac.wordpress.org/attachment/ticket/12648/wpmu-create-blog.patch

    This works fine. The line Number of this patch is not the same, becouse it’s an older WP version
    Why isn’t this fixed on wordpress 3.0?

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Note this ticket:
    http://core.trac.wordpress.org/ticket/12028

    It;s been punted for future release. It’s not considered a deal-breaker or blocker, because even in the regular userbase of what was mu, creating blogs in bulk wasn’t used by the majority.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘wpmu_create_blog bug?’ is closed to new replies.