Support » Networking WordPress » wpmu 2.9.2 to 3.0 pages & posts no longer work

  • rmiddleton

    (@rmiddleton)


    After upgrading to 3.0 the main site appears fine but none of the others work. Main page on each comes up with correct theme, but pages & posts that existed are Error 404.
    Did modify .htaccess & wp.config.php per note at the end of the upgrade process. (copy/paste so not likely a typo)
    Example: This site has/had 15 pages and at least 1 post.
    http://websites.msdpt.k12.in.us/sample/
    u=sample p=letmein
    Appreciate any direction / thought you may have.

    RewriteEngine On
    RewriteBase /

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

Viewing 15 replies - 1 through 15 (of 21 total)
  • Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    The main site still shows the maintenance mode screen?

    rmiddleton

    (@rmiddleton)

    Yes, that only affects the main site. Wish it affected all! However, I’ll take it down for you (despite the calls I’m going to get) becuase I really am getting frustrated! Everything was PERFECT before the upgrade. Going live 7/1!!!

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    And in the admin area it says you have no posts or pages found, even tho it gives a count. 😉 Different thread title for troubleshooting.

    hang on, I’ll go see what I can find.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Can you disable all the plugins, including network activated and anything in the mu-plugins folder?

    also, have a look in the db – none of the posts have assigned categories. Something didn’t complete & Ron and I are wracking our brains trying to remember. (we have seen this before)

    rmiddleton

    (@rmiddleton)

    Okay, all deactivated.
    Page & post data is in database.
    One entry from wp_2_posts:
    11 1 2010-04-05 19:43:00 2010-04-05 19:43:00 Parents publish closed closed parents 2010-04-05 19:43:00 2010-04-05 19:43:00 0 http://websites.msdpt.k12.in.us/sample/?page_id=11 4 page 0

    rmiddleton

    (@rmiddleton)

    Okay, now it’s magically back!!!

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Yay?

    ;D

    (kinda disturbed we don’t know why it’s suddenly working…)

    Was it one of the plugins maybe?

    rmiddleton

    (@rmiddleton)

    I’m really disturbed by that too. I have put them back, one at a time, all is well. I guess we’ll have to “assume” it was, but…
    Unsolved fixes worry me as much as unsolved problems.
    Thank you for the help. As always, you are great!

    rmiddleton

    (@rmiddleton)

    All is not totally right with the world…
    Most sites are back okay. Some still show pages/posts count but do not appear in the list for editing.
    So, did you remember where you have seen this before?

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Still drawing a blank. Hard to find with searches.

    gazouteast

    (@gazouteast)

    Same issues as rmiddleton on one of my sites too – have tried everything I can think of, and still looking for additional clues from others.

    I’ve checked and recheckedthe subdomains’ setups – all is as should be, in the database, in the Super Admin’s – Sites – Edit, in theme and plugin options (yes, tried with twenty ten and zero plugins but still same errors). Have created new htaccess and no joy.

    The theme (whichever one) shows correctly, but on the public side every query is Sorry not found – home page, category pages, single posts, pages … even the 404 page returns “sorry nothing found” – LOL

    Andrea – please prod Ron and try to find where you saw this before, somewhere there is a disconnect between the post lists in the side bar and admin (which both show the right counts) but even in admin, if I click the posts list link, it says no posts, yet above that gives the count for the number of posts … they’re in the database alright, but not being returned to the site.

    Am starting to think this is template tag or core function related, rather than something more obvious like database connect or htaccess – there were a LOT of template tag deprecations in the WP 3.0 changelog.

    Gaz

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    If you tried it with TwentyTen & got the same issue, then it;s not a template tag. 😉

    Did you go resave the permalinks on that one blog?

    In the case of middleton above, it could be that he’s on one of thsoe hosts that take ages to let any htacces changes show. hard to say.

    But his was *all* blogs. Yours is one blog. That means different cause.

    So. Go to that blog’s permalinks page. Pick a different permalink, save. then pick the one it was. Save. Go see if that fixes it.

    gazouteast

    (@gazouteast)

    Tried every theme including 20-10, kubrick etc – all yield the same

    permalinks changed and saved upteen times (with htaccess on 777) on home and sub-blog – no fixed (broke it more and had to refix back to original broken state)

    my linked site only has one sub-blog right now – it was a part done 2.9.2 build that I upgraded to 3.0 as a testbed (I’m assuming you looked at checkedbyyou.com ?)

    Even went to the stage of renaming plugins and using an empty plugins folder just in case Hello Dummy was the cause.

    No joy – now looking like the third brother to Yul Bryner and Telly Savalas – (rolls eyes for showing my age – LOL)

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    No joy – now looking like the third brother to Yul Bryner and Telly Savalas – (rolls eyes for showing my age – LOL)

    I know who these guys are. 😉

    my linked site only has one sub-blog right now – it was a part done 2.9.2 build that I upgraded to 3.0 as a testbed

    try a fresh install?

    What’s the second site on your domain? It’s not linked to anywhere. kinda hard to check that way.

    gazouteast

    (@gazouteast)

    sorry Andrea – chasing my tail in too many directions at once with this

    The “test anything and cross fingers” site, which was MU2.9.2 and is now 3.0 multisite (subdomain in both cases) is –
    (top) http://checkedbyyou.com
    (sub) http://webhosting.checkedbyyou.com

    in the sub – note the two test post titles in the sidebar under recent posts – WP is speaking to the db and retrieving post meta etc, but not displaying it (all themes) as posts on the main part of the page – not even the title, which we know it’s got because it’s in the side bar.

    It’s doing the same in admin – go to the Posts list page, and it says how many posts in the database and whether published, draft etc, but does not show the list of posts and their details.

    If you want a superadmin login to play and investigate gimme a nudge and contact path to send the info – I’ll even give you an all-privileges FTP user account for that domain if you want to look deeper – I’m completely stumped – I’ve had a full week looking at nothing else and trying everything.

    Gaz

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘wpmu 2.9.2 to 3.0 pages & posts no longer work’ is closed to new replies.