WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] WPML with a static front page

[Resolved] WPML with a static front page

  • Hi all,

    Since I can not post this answer in the WPML forum and as far as I can see nobody has answered the many questions about this there I thought I post my solution here.

    Here’s the problem:
    When you set a static front page in WordPress and use the WPML language switcher to select a different language the front page will show the blog posts and not the static page.

    Here’s my solution:
    Go to WPML > Languages and set the how to determine which language visitors see contents in to Different languages in directories.

    There’s a nice side effect though: I have a NextGen gallery slideshow (Flash based one) that could not retrieve any images when I switched to a different language. This is fixed now as well!
    2 birds, one stone, one happy customer. 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • katootje

    @katootje

    I have the same problem here. Had my site completely in Dutch and switched to bilingual with WPML. Slideshow is working perfectly on the dutch part, but only the turning waitingwheel is showing on the english part of the website. I had already the option set at how to determine… to different languages in directories, but slideshow is not working.
    No caching plugin set.

    Hoi Katootje, did my solution work for you?

    Nope
    See http://www.motivaxion.nl/en/
    and it’s working great at the dutch part. Do you think because of the /en/ in the url he is looking on the wrong place for de player? I haven’t check that out yet. Easy to make a kind of fake directory with the player.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] WPML with a static front page’ is closed to new replies.
Skip to toolbar