Support » Plugin: Events Manager » WPML Event Search Form translations

  • Resolved jeffinmotion

    (@jeffinmotion)


    Hello,

    I’m using Events Manager on a Multisite installation with WPML (so I’m also using the Events Manager and WPML Compatibility plugin). I only have 2 languages, English and German, with the default language being German.

    I’ve created both German Events page (using the CONTENT option, to allow me the option to add content above and below the search form / listings) and configured it as the Events page under the Event List/Archives setting. I also have translated that German page to English, and can view the page and search my events, but the problem is: when viewing the site in English, the events search form is still displaying in German. How can I force the search form to honor the viewing language of the site, instead of using the default?

    Thanks,
    Jeff

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support angelo_nwl

    (@angelo_nwl)

    do you have sample link to your site with this issue for us to see and analyze? also, what is your current EM version?

    jeffinmotion

    (@jeffinmotion)

    Hi @angelo_nwl,

    My apologies for the slow response—I didnt seem to get a follow-up email.

    EM version: 5.8.1.1
    EM WPML: 1.0.1

    Our site is on a staging server that requires basic auth access, how can I securely send you the credentials?

    Edit: I have sent you the access info via your contact form on your website: http://wp-events-plugin.com/contact-us/

    Best,
    Jeff

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    Hi Jeff,

    The reason would be because you haven’t translated the fields on the search form. Because they’re custom values, you need to translate them. Click the globe on the right of each label in Events > Settings > Formatting > Search Form and translate it.

    @netweblogic thanks so much! I absolutely missed the little globe. All set now.

    Best,
    Jeff

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.