Support » Plugin: Duplicate Post » WPML Compatibility Issue – Translations missing in clone

  • iltel

    (@iltel)


    Hello,

    First of all, thank you so much for this great plugin which we have been using often for more than 2 years now.

    I would like to report an issue that has recently arisen (can’t tell exactly when), which is identical to an issue we have reported more then a year ago in this ticket.

    This new issue again concerns cloning post/pages which were translated using WPML.

    The issue, simply put:

    1. Our website’s main language is English. Secondary is Hebrew. All plugins, theme and WP versions are up-to-date.

    2. We translate all our content using WPML Translation Editor.

    3. Recently, when we clone a post/page or any of the post types which we selected in your plugin’s settings, the Hebrew translation is not cloned. Instead, the Hebrew fields in the translation editor, are populated with the English Original.

    4. Being one of the most seasoned WPML users, with many WPML support miles, I can tell its a compatibility issue, which most probably went sour with one of WPML’s plugins version updates.

    5. Off-course, we managed to find a temporary workaround which most probably could indicate were the problem lies (this workaround is as a very prevalent recommendation by WPML support, whenever a translation is missing in translation editor, not necessarily with your plugin, but in many other situations):

    In the cloned post/page, on Page Edit, you need to make a small change to the English version (the main language) of EACH element/item found in the page/post, save it (update), and then when you push the circular icon to get to the translation editor, you will see the missing Hebrew translations in place, for those items to which you made this small change.

    Off-course, this is just a temporary workaround, which is very labor intensive.

    But as I said, the workaround which works, clearly indicates where the current compatibility problem lies.

    Thank you,

    Noam

Viewing 15 replies - 1 through 15 (of 20 total)
  • Dear plugin developer,

    I reported this issue to WPML support as well.

    They asked me if you are aware of this issue.

    Will appreciate your reply,

    Noam

    Dear plugin author,

    As a follow-on to my previous message, this is the link to the WPML support ticket I filed:

    https://wpml.org/forums/topic/all-translations-missing-in-all-post-types-cloned-with-duplicate-post-plugin/

    Thanks,

    Noam

    ????

    Dear plugin developer,

    WPML support have just reported an issue with your plugin.

    They asked me to notify you and I promised to post it on this forum.

    Here is the link to the WPML support ticket.

    This was their last message from today:

    Hi Noam,

    After applying the steps I found this error:

    1
    [02-Jul-2019 16:24:37 UTC] PHP Notice:  Undefined variable: post_type in /home/krollcon/staging/1/wp-content/plugins/duplicate-post/duplicate-post-admin.php on line 304

    I suspect this is the error that is causing the issue. Because the issue persists while all plugins are deactivated except WPML plugins and required plugins, and the parent theme is active.

    Please confirm that the issue persists so I can escalate this ticket.

    I also recommend you to update the plugin’s authors about this issue.

    Regards,
    Carlos

    Thanks,

    Noam

    Plugin Author Lopo

    (@lopo)

    Hi @iltel,
    sorry for the delay.
    That’s absolutely an unfortunate error which I am going to fix in the next version by the end of the week.
    I hope it will fix the issue for your customer.

    Thank you for pointing out the error!

    Thank you so much for your reply.

    I will update WPML support.

    Regards,

    Noam

    Hello Lopo,

    A question please:
    Are you still planing to publish the next plugin version with the fix, by tomorrow?

    Thank you,
    Noam

    Plugin Author Lopo

    (@lopo)

    Hi @iltel,
    I think it will take a couple of days more because of another bugfix which needs tests…

    Hi Lopo,

    Thank you very much for the update!

    Regards,

    Noam

    Plugin Author Lopo

    (@lopo)

    Hi @iltel,
    version 3.2.3 is out now, fixing the issue. Hope it will be helpful for your customer!

    Hello Lopo,

    Thank you so much for the update. Greatly appreciated!!

    Best Regards,

    Noam

    iltel

    (@iltel)

    Hello Lopo,

    Hope you are well.

    After running endless tests, I would like to report:

    The fix doesn’t work and the problem persists.

    The WPML translation is not cloned.

    Can you please check?

    Thank you so much.

    Noam

    iltel

    (@iltel)

    Hello Lopo,

    As a follow-on to my previous message:

    To be more specific – the issue is with the Visual Composer Sidebars.

    When you clone them, their translation is not cloned.

    WMPL confirmed this

    – please see link to the same WPML support ticket (I have already sent a link to, above) in which WPML confirmed today this issue and asked me to inform you of the issue.

    Thank you,

    Noam

    Plugin Author Lopo

    (@lopo)

    Hi @iltel,
    I thought you already checked by fixing the line giving the warning…
    I don’t own any Visual Composer Premium license so I can’t do any tests on Visual Composer Sidebar.
    If I could access your client staging website, including its database, I might be able to understand how a Visual Composer sidebar is stored and figure out the issue…

    iltel

    (@iltel)

    Hi Lopo,

    Thank you so much for your response.

    1. First – please let me say that the website concerning is my own (my company’s) 🙂

    I am not a professional website developer/or coder – I am just a very seasoned self-taught website development enthusiast.

    2. When you say: “I thought you already checked by fixing the line giving the warning”
    I am not sure what you mean by that – all we did was waiting for the updated plugin version assuming it contained a fix for this issue.

    Were we wrong?

    3. In any case, I will be very happy to grant you access to our staging website, which is a full and complete clone of our live website.

    Please let me know how to send you the credentials.

    Thanks!

    Noam

Viewing 15 replies - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.