Support » Plugin: 404page - your smart custom 404 error page » WPML causing issues with the 404page plug-in

  • Resolved merijn70

    (@merijn70)


    Hi Peter,

    My 404 pages display an empty body..

    I’ll try to explain my situation and what I discovered:

    Introduction
    My WordPress and all my plugins are running the newest/latest version. My theme is Avada but my issue also occurs on Twenty Nineteen. In the topics I see some people with similar issues but in my case i found out that WPML is causing the issues in combination with the 404page plugin.

    The problem
    If I enter an invalid url I get an ’empty’ 404 error page, the page title is as set on the desired 404 page ‘Pagina niet gevonden (404)’ and ‘Page not found (404)’.
    Note: By empty page I mean no body and no slider. The logo, menu and footer are displayed correctly.

    The situation
    I have a multilingual website and use quite some plugins. All plugins and the themes are the latest version. All running smoothly.

    What I discovered

    • When I switch to the Twenty Nineteen theme the issue still exists.
    • When I turn of all plugins the issue is resolved.
    • With all plugins activated except the WPML Multilingual CMS plugin the issue is resolved.
    • With all plugins deactivated and only WPML Multilingual CMS plugin and the 404page plugin on using the Twenty Nineteen or Avada theme the issue still exists.

    Conclusion
    There seems to be an issue with the 404page plugin combined with WPML.

    Links

    Versions

    • WordPress: 5.2.3
    • Avada: 6.0.3
    • 404page – your smart custom 404 error page: 11.0.3
    • WPML Multilingual CMS: 4.2.8

    Other plugin info on request.

    Hope this can be fixed because I really like your plugin..

    Merijn

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • I have the same issue I think: A blank page shows up with the correct title. I also use WPML, also with Dutch, but with a different theme and a bunch of other plugins.

    I have tested with the 404 plugin disabled (shows default 404 again) and with the caching plugin (WP Rocket) disabled (didn’t help). I can’t test much more right now.

    Hi,
    Same issue here, only the default language is showing content.

    Plugin Author Peter Raschendorfer

    (@petersplugins)

    Sorry, there was a bug in version 11.0.x concerning WPML compatibility. Fixed in version 11.0.4. Please update and let me know if it works.

    Regards,
    Peter

    Thanks Peter, the update fixed it for me.

    Regards,

    Someone who is called Plugin Peter by friends 🙂

    Plugin Author Peter Raschendorfer

    (@petersplugins)

    Thanks @brinkz0r for your feedback. I’m very happy that it works

    Plugin Author Peter Raschendorfer

    (@petersplugins)

    @merijn70, @saharusa is it working for you too?

    merijn70

    (@merijn70)

    Hi @petersplugins,

    I did test it and I am afraid that I am heading another issue but I did not have time to dive into the problem. The selected 404 page is not loading now.

    I use the Avada theme and I think Avada generates also a 404 page.. I am not sure how to fix this..

    Kind regards, Merijn

    • This reply was modified 3 months ago by merijn70.
    Plugin Author Peter Raschendorfer

    (@petersplugins)

    Marked as resolved.

    If further problems occur, please start a new topic.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.