• Hi,
    today’s update to wp3.1 broke part of my multilingual system. I’m using WPML 2.0.4 and it works on pages but trying to access a blog category (or tag list) I get the following error:

    Warning: reset() expects parameter 1 to be array, null given in [...] /query.php on line 2890

    Anyone having the same problem? Any fixes? Does anyone know if the free version of WPML is still under development?

    On the WPML website they talked about this issue, stating that they fixed it for the commercial version (29$ – 79$) 2.1.1


Viewing 7 replies - 1 through 7 (of 7 total)
  • All WPML development has moved to WPML.org.

    We’re not maintaining two versions, a free and a paid one.

    WPML 2.0.4 which you can get from the WP plugins repository is the last version that we released before making the plugin commercial.

    It works on WP 3.0.5 but has numerous bugs on WP 3.1. At the time WPML 2.0.4 was written, WP 3.1 didn’t exist, not even as Alpha, so we couldn’t test it.

    Thread Starter fred0815


    I guess I found a workaround… not the most elegant solution but it seems to work…. Instead of calling a category directly, I created a Page, which contains all the posts of a category…. So when I open this page I see all my posts as I did before the update without any error message…

    How to do this?

    1. Install and enable the Allow PHP in Posts and Pages Plugin

    2. Create a new Page and insert the following code:


    Change the x to the ID of the category you want to show.

    3. Change the links in your menu that directed to the category for links to your newly created Page

    4. I had to change some CSS in order to fix some little design problems

    Repeat steps 2-4 for all your categories in all languages…


    Does this bug exist also when using WP 3.1 with WPML 2.1.2 (commercial)?

    There are no known bugs in the commercial versions. We’ve cleaned over 300 bugs going from WPML 2.0.4 to these versions.

    I found out how to fix it under WPML 2.0.4.x on WordPress 3.1.

    function get_term_link in "wp-admin/taxonomy.php"
    Line 2846: $termlink = "?$t->query_var=$slug";
      Change to: $termlink = "?$t->query_var=$slug".'&cat='.$term->term_id;
    Line 2849: $termlink = "?taxonomy=$taxonomy&term=$slug";
      Change to: $termlink = "?taxonomy=$taxonomy&term=$slug" .'&cat='.$term->term_id;

    This problem is the change of category process.
    Wordpress 3.1 uses “category_name” instead of “cat”.
    “cat” means the category id.
    Therefore, I added “cat” query to URL.

    Of course, I hope that this problem is resolved in latest version of WPML (2.2.x).

    hi all.
    I also have the same proplem.
    When my page in english language, get_term_link work fine. Link is: http://homepage/category/drill. But when page in vietnamese language, get_term_link work wrong, link is : http://homepage/vi/vi/category-vi/drill-vi.
    I don’t know why :((. help me

    I think that this issue was solved by WP3.1.1.

    Detail information is the following URL.


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WPML causes error: query.php on line 2890’ is closed to new replies.