Support » Networking WordPress » WPLANG setting not getting saved

  • Resolved alininja



    I’m trying to set the WPLANG setting of one of the sites on my network. I get the “Site options updated” confirmation message, but the WPLANG field is still blank. And when I query it with get_locale(), I’m still getting the default ‘en_US’.

    Any ideas as to why it’s not saving the WPLANG setting?

    I’ve tried:

    Thank you for your time!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The format is : define ('WPLANG', 'pt_BR');

    But you may want to read this:

    (My kanjii is limited to counting to 7…)

    Hi Ipstenu,

    Thank you for the reply. I tried what you suggested but it still didn’t save. I forgot to mention that I’m not trying to edit the wp-config.php file. That works fine but only controls the primary site. I’m trying to use multisite’s admin panel to set the wplang for other sites in the network.

    I’m not sure if that matters, but I just feel like I’m missing something very trivial.

    Also, I looked over your link but everything was in Japanese when I tried to look for information about setting the wplang to be Japanese. Though I just want the static page content to be Japanese, not the entire backend of the site.

    Sorry if my questions seem strange. I’m trying to orient myself in this new wp multisite system.

    Thanks again for your time!

    Wait… what?

    You just want to have Japanese content on one page of a site?

    Hi Ipstenu,

    Thank you for the quick turn around.

    I basically want:

    Where is the Japanese version of

    I’ve got the po and mo files working for the primary site. So whenever I switch the wplang in the wp-config.php file the textual content changes accordingly. But since I can’t get the wplang to change for the other sites, the textual content isn’t changing. The po and mo files are tied to the theme so it should work the same for all the sites, I think.

    I hope I’m making sense. I don’t think this wplang not saving issue is a database problem because all of the other settings and page content is stored and retrieved perfectly.

    Thanks again for your time!

    It’s not your DB.

    You need to upload the mo/po file for Japanese to wp-content/languages. That will give you the ability to select the language per site.

    But I’m pretty sure that’ll change the back end too.

    Thank you Ipstenu!

    That’s the last step that I missed…saving the .mo file to wp-content/languanges.

    I had only saved it to wp-content/themes/mytheme/languages.

    It only makes sense logically now in retrospect that that was no the right place to put it.

    The backend still looks the same, but the WPLANG gets saved!

    Thank you thank you!

    Hi Ipstenu,

    Just out of curiosity, is this the best way to accomplish a multilingual site with subdomains, using WordPress?

    The solution is nearly perfect except for the fact that I need to recreate each static page for each subdomain, even if I’m using .mo translation files.

    Any advice or input is greatly appreciated!

    Thanks again for all your help. Take care!

    I really don’t know what the ‘best’ way is yet :/ No one’s come up with a fool-proof one.

    Gotcha…thanks a million for your help again!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘WPLANG setting not getting saved’ is closed to new replies.