Support » Plugin: WPGlobus - Multilingual Everything! » WPGlobus Langage menu not working in top navigation

  • Resolved missogra

    (@missogra)


    Hello,
    Iā€™m getting an issue when using the WPGlobus plugin in conjunction with the graphene theme.
    When clicking on the language button, no popup opens to show the various languages available.
    Did I miss an extra configuration step to make it work or is it just not supported ?
    Any help is highly appreciated!
    PS: The link of my site to see what I mean: https://discourselab.de

    Regards,

    Carolina

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • @missogra

    Hi Carolina, indeed, there is only one flag in the language switcher.
    Please check if the problem persists if you switch the theme to another one.

    Thanks
    Gregory

    Hi Gregory,

    thank you very much for your answer. I changed the theme and the plugin works fine. So now I know there must be a compatibility problem. Can something like this be resolved with CSS or do I have to change from WPGlobus to another plugin? I’m sorry if the question sounds a little strange. I’ve been in charged of that site for about a week now and I don’t have previous experience with WordPress, so I just started learning.

    Regards,

    Carolina.

    It does not look like a CSS problem.

    Please go to admin -> WPGlobus -> Help Desk and submit a support ticket.

    We’ll continue from there.

    Thank you!

    Thanks! The problem was reselved with Alex’s code:

    jQuery(document).on('mouseenter', '.wpglobus-current-language a', function(evnt){
    	jQuery('.wpglobus-current-language ul.dropdown-menu').css({'display':'block'});
    }).on('mouseleave', '.wpglobus-current-language a', function(evnt){
    	jQuery('.wpglobus-current-language ul.dropdown-menu').css({'display':''});
    });

    Hi Caroline,

    may I ask where did you add the a.m. code from Alex?
    I have the same problem, but only when viewing the page on a small (phone, pad)-layout in normal-wide layout it works ok.

    thanks in advance for a sort notice.
    best regards
    Juergen

    Plugin Contributor Alex Gor

    (@alexgff)

    @juergenp
    > where did you add the a.m. code
    There is Custom JS option on WPGlobus Settings page in admin.

    Hi Alex,
    thanks!
    I added the code at this position, but it doesn’t solve my problem at all šŸ™
    I guess the problem is related to Android (or other) and not using a mouse. It’s difficult with fingers to “hoover” :-O and after touch the first language the menu dissapears. May be I have to check forum for another solution.

    Plugin Contributor Alex Gor

    (@alexgff)

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WPGlobus Langage menu not working in top navigation’ is closed to new replies.