Support » Plugin: IP Geo Block » WPGlobus compatibility with IP Geo Block

  • Before the latest update, WP Globus worked on my theme. After the update, I do not know what happened, but if I attempt to toggle to the second language, IP Geo Block blocks the request and gives me the default error message. What is it about toggling to the second language verion of a page would trigger IP Geo Block into blocking the request, even from the ip of the admin? It should never be block at all, front end or back end.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi @fraughtithrouble,

    I’m very sorry for this issue and your inconvenient.

    I’ve noticed this kind of incompatibility issues with some plugins and themes. So I’m now working hard to fix these and I appreciate you to keep using the previous version that you can download from https://downloads.wordpress.org/plugin/ip-geo-block.2.2.9.1.zip

    Thanks for your reporting!

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi @fraughtithrouble,

    Although I updated this plugin to 3.0.1, I’m worried it wouldn’t fix this issue. I installed and tested WPGlobus in my test site but I couldn’t reproduce the issue even with 3.0.0. I think that settings for WPGlobus is not different from yours. For example, I can’t find how to setup “Language Selector Menu” that says “No items of this type were found.“.

    Anyway, I’d appreciate you to try v3.0.1 and please let me know “Installation information” that is a new function in 3.0.1. Please refer to “3.0.1 Release Note” and “Why “You are not allowed to access this page” ?“.

    Thanks.

    Thread Starter fraughtithrouble

    (@fraughtithrouble)

    Thanks, Tokkonopapa, for replying, I really appreciate the attention from the author of the plugin for this issue.

    As far as I understand it, since WPGlobus, when you select via the flag on the menu the alternate language, calls a url which does not exist in the format

    domainname/2letterlanguagecode/pagename

    whereas the real page is at

    domainname/pagename

    Loginizer reacts to such a url call as if that page did not exist and responds as if it were a 404 call…

    So somehow, if Loginizer is to work with WPGlobus it must allow the exception for that plugin calling a virtual but not actual url. Perhaps Loginizer could whitelist the plugins which are installed and active when they do things like this?

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi @fraughtithrouble,

    Thank you for the information about WPGlobus and Loginizer.

    I’ve confirmed that WPGlobus provide flags at the bottom on front-end pages and top menu bar on dashboard. In my case, first flag is English and 2nd flag is Japanese. Both of them works fine. I think the method of parsing virtual URL in WPGlobus has no concern with IP Geo Block.

    As for Loginizer, it also works good. IP Geo Block also has the similar functionality but I cound not find any conflict when both are activated. I think you need nothing special about these.

    So unfortunately, I can’t find a solution for this issue. I hope you to have another chance to try my plugin, and when you encounter the blocking issue again, let me know “Installation information” especially the part of error logs:

    Installation information

    If I can get the cause of this issue from that information, I can tell you what we should do next.

    Thanks you so much.

    Thread Starter fraughtithrouble

    (@fraughtithrouble)

    OK, here is the installation info, given by your plugin…

    – PHP 5.6.27
    – BC Math yes
    – mb_strcut yes
    – WordPress 4.7
    – Multisite no
    – Experon Pro 1.6.7
    – Akismet 3.2
    – Anti-Malware Security and Brute-Force Firewall 4.16.39
    – Black Studio TinyMCE Widget 2.3.1
    – Block Bad Queries (BBQ) 20161114
    – Contact Form 7 4.6
    – Contact Form 7 – PayPal Add-on 1.3.4
    – Copyrighted Post 1.2.18
    – Easy Digital Downloads 2.6.14
    – Easy Updates Manager 6.2.9
    – Email Address Encoder 1.0.5
    – Fast Secure Contact Form 4.0.44
    – Gauntlet Security 1.4.1
    – IP Geo Block 3.0.1
    – Loginizer 1.3.2
    – Page Builder by SiteOrigin (ThinkUpThemes compatible) 2.4.8
    – PayPal Donation 1.2.2
    – Remove Footer Credit 1.0
    – Send Email From Admin 1.0
    – Subscribe Button by AddToAny .9.10.0
    – Theme Check 20160523.1
    – Theme Preview 1.4
    – Tweet Wheel 1.0.8
    – WaspThemes – Yellow Pencil Pro 5.5.0
    – Wordfence Security 6.2.8
    – WordPress Social Sharing Optimization (WPSSO) 3.37.8-1
    – WP Author, Date and Meta Remover 1.0.4
    – WP Edit 4.0
    – WPGlobus 1.7.1
    – WP Spell Check 5.3
    – WP Statistics 11.0.2
    – WP Subscribe 1.1.3
    – 2016-12-14 13:58:42 wp-zep POST:/wp-admin/admin-ajax.php
    – 2016-12-13 22:31:18 wp-zep POST:/wp-admin/admin-ajax.php
    – 2016-12-14 13:58:42 wp-zep GET:/wp-admin/admin.php?page=WordfenceActivity&ip-geo-block-auth-nonce=…
    – 2016-12-13 15:20:06 wp-zep POST:/wp-admin/admin-ajax.php
    – 2016-12-13 17:18:14 wp-zep POST:/wp-admin/admin-ajax.php
    – 2016-12-13 21:16:56 wp-zep POST:/wp-admin/admin-ajax.php
    – 2016-12-14 13:58:42 wp-zep POST:/wp-admin/admin-ajax.php

    Thread Starter fraughtithrouble

    (@fraughtithrouble)

    Excuse me for saying “Loginizer” in my previous post, I meant to say “IP Geo block”…that is the plugin I believe is conflicting with WP Globus.

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Dear @fraughtithrouble,

    I deeply appreciate your great effort and info!

    I will try to be able to get the result and inform you after examining them. So please give me some time.

    Thanks again!

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi @fraughtithrouble,

    I’m sorry to have kept you waiting. Here is my intermediate report.

    I installed all the plugins except Yellow Pencil. Theme is free version of Experon 1.1.0 By ThinkUpThemes.

    I found 2 errors and reported to the authors:

    https://wordpress.org/support/topic/should-not-hard-code-the-url-to-logo-icon-16×16-png/
    https://wordpress.org/support/topic/segmentation-fault-11-2/

    But those are not related to this issue.

    And also found one conflict with Anti-Malware that is not also related to this issue. When I “install Patch” at “Brute-force Protection” on “Firewall Options” and then logged out, I couldn’t log in again and got a message “You have been redirected here from localhost which is protected by GOTMLS Anti-Malware” because of redirection to “http://safe-load.gotmls.net/report.php?ver=4.16.39&…”. This was caused by blocking a ajax request on the login form in terms of WP-ZEP of IP Geo Block. So I recommend to disable Anti-Malware Brute-Force Protection.

    Well, I keep going to investigate the issue. Please do not waste your time to respond to this post.

    Thanks.

    • This reply was modified 4 years, 11 months ago by tokkonopapa.
    Plugin Author tokkonopapa

    (@tokkonopapa)

    I’ve been struggling with many PHP warning that came from the plugins you are installing. (Tweet Wheel, GOTMLS, Wordfence, Theme Preview, Gauntlet Security, WP Spell Check, …You can find these warnings when you enable debugging mode. As a developer, I can’t believe why so many plugin authors leave them!)

    And unfortunately, up to now I can’t find the cause related to this issue. I’ll release a new version with a potential solution against this issue in near future as well as some small bugs fixed.

    I hope you to try it.
    Thanks.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘WPGlobus compatibility with IP Geo Block’ is closed to new replies.