Support » Plugins » wpgform unable to retreive Google forms after changing site url

  • I recently made changes to the ‘site adress’ url to make it look as if the website was run from the root instead of the blog/ subfolder.

    I made changes to .htaccess and now everything seems to work with the exception of Google forms. On any Google form (that worked before) I get the message “Unexpected content encountered, unable to retrieve Google Form.”

    Is there any setting or .htaccess rule I did not implement in order to make the wpgform plugin work correctly?

Viewing 11 replies - 1 through 11 (of 11 total)
  • No, there isn’t anything special that WordPress Google Form does with permalinks. The custom post types WordPress Google Form uses are no different than any other post type with respect to URLs. Did you re-save your permalinks setting? I believe it is recommended practice after a blog address change.

    Thank you for your reply.
    I did re-save the permalink settings, to no avail.

    There are some other minor issues on the website that might be related (comment icon is not displayed).
    I created a child theme, by the way.

    So you’re suggesting that the problem I have is not wpgform related but another cause that happens to also affect Google forms?

    My guess is you likely have a plugin or theme conflict. That is is the easiest thing to rule out. You can disable all plugins except wpGForm and see of the problem persists. If it does, then I would switch to one of the WordPress default themes (I like TwentyTen) and again, see if it persists.

    If you’re still having the problem after trying those two thing let me know and there may be something else we can try. I do have a beta version available that may be worth a shot as it fixes a couple of minor bugs.

    Hi Mike, I tried disabling all plugins, re-saved permalink settings, then also changed to default twenty-eleven theme, re-saved permalink settings. No joy.
    The standard theme does have full functional icons while my child theme doesn’t.
    By the way… does the child theme have to be INSIDE the directory of the parent theme or on the same level? (I now have it on the same level).

    I did not yet try the beta version.

    the changes I made was that I made the website in the folder ‘blog’ available from root and also implemented a rule in order to rewrite http://www.domain.com to domain.com

    I just removed the plugin and installed the beta version. No joy. The strange thing is that everything did work after installing it for the first time…

    I made a fresh install of wordpress (including fresh .htaccess), installed the WPGforms plugin, installed the SEO plugin from Yoast and made a change to the permalink settings. Same error.
    It has worked before after installing the Yoast plugin, so my guess is a conflict with the permalinks or something totally different… but how to find out what is wrong?
    None of the permalink settings give a solution.

    If you would be willing to analyze what is wrong (I’ll give a login account), I’ll be very happy. But if you give up on me I also understand.

    If you can set me up with a login with Admin access I’d be happy to look at it. My email is my WordPress username at gmail dot com.

    Thank you very much Mike, for your offer. You’ll receive an e-mail very soon with user credentials.

    It looks like your site has the same issue with the cURL transport as one I looked at a couple weeks ago (and drove the changes in v0.54). The only thing that seems to be common between the two sites that have this problem is a recently built version of PHP.

    Turning off the cURL transport on the Settings->Google Forms->Advanced tab appears to have solved the problem.

    Thank you so much Mike! Everything seems to work fine now. Then apparently the provider updated the php version, though I don’t remember any announcement on that.
    You’re awesome!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘wpgform unable to retreive Google forms after changing site url’ is closed to new replies.