Support » Plugin: wpForo Forum » WPforo Captcha Not showing in the Form

  • Resolved naomibuch

    (@naomibuch)


    Hello…

    I love the plugin! but I am experiencing a couple of issues.

    1. The Captcha does not display of the Login or Registration form, instead it’s showing at the bottom of my website page when I put in the site key and secret key from Google.

    2. During testing when logged out the green indicator button still appear when I browse the forum when logged out for a particular user, not all users, only moderators and Admins.

    3. When I install Google Captcha (reCAPTCHA) by BestWebSoft plugin, the captcha is positioned correctly and works fine, but the Captcha is still appearing at the bottom page of my website, in other words I have 2 Captcha’s one in the correct position and one at the bottom page.

    4. When I remove the site key and secret key in Wpforo Forum->Tools the extra Captcha disappears from the bottom of my page website. But when I activate the plugin Google Captcha (reCAPTCHA) by BestWebSoft it appears in two places.

    Kindly help me with these issues asap.

    BTW: I have purchased two of your addon’s and they work perfectly.

    Naomi

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author gVectors Team

    (@gvectors-team)

    Please uninstall all reCAPTCHA plugins, then create new reCAPTCHA API keys. Make sure you create reCAPTCHA version 2 not 3 (invisible). Then put version 2 reCAPTCHA keys in Forums > Tools > Antispam Tab. Save it, delete all caches, logout, press Ctrl+F5 on registration page and test it.

    Thanks I will try that, then I will let you know if it works.

    Naomi

    Hello…

    I tried all steps plus went above and beyond…btw: I am a software developer…and the Google Captcha is now throwing an error when I put the new site key and secret key in forums tools, the following error: ERROR for site owner: Invalid site key

    I then removed both keys from wpforo forum tools, and the error disappeared at the bottom of the page, it still was not in the correct position, near the login.

    I then reinstalled the plugin Google Captcha (reCAPTCHA) by BestWebSoft, for testing to make sure the Google reCaptcha had the correct keys, and I was then able to log in.

    I did further testing and wanted to deactivate wpforo and uninstall it and the crashed my website….IT THROWS THE FOLLOWING ERROR: The site is experiencing technical difficulties.

    I CAN NOT REMOVE THE PLUGIN OR I CAN’T ACCESS MY WEBSITE….PLEASE HELP ASAP…

    Plugin Author gVectors Team

    (@gvectors-team)

    As I said you should not install other plugins. So here is the result you see. You still do something incorrect. Thousands of websites use wpForo reCAPTCHA without any issue, we’ve never faced with such problem with the latest wpForo version.

    Now, just use your Hosting cPanel > File Manager Tool, navigate to /wp-content/plugins/ and remove the folder of reCAPTCHA plugin. If it doesn’t help, remove the wpForo folder too. This will not remove any data. Then login and install wpForo again.

    For correct reCAPTCHA configuration please open support topic at wpForo Community. Our support team will help you: https://wpforo.com/community/

    Hello…

    I finally got it all worked out….but sadly I couldn’t get the wpforo captcha to work under tools, it still place the captcha in the wrong position in the bottom of my page.

    I just had to remove both keys from the wpforo forum tools and installed Advanced noCaptcha & invisible Captcha (v2 & v3) plugin and it works perfectly and don’t display two captcha’s.

    I do have another issue, that occurs sporadically with the users avatars, when browsing the forums when logged, the avatar does not show, however when I log out I can see all avatars.

    Any ideas?

    Thanks

    Naomi

    Plugin Author gVectors Team

    (@gvectors-team)

    V3 reCAPTCHA is designed to display in the bottom side of pages. All is correct. For further questions please contact to that plugin developers they’ll explain you what is V2 and V3 reCAPTCHAs.

    I do have another issue, that occurs sporadically with the users avatars, when browsing the forums when logged, the avatar does not show, however when I log out I can see all avatars.

    This maybe a permission issue. Navigate to Dashboard > Forums > Usergroups admin page, edit the Guest Usergroup and enable “Front – Can view avatars” option. Then delete all caches and check it again.

    Hello again…

    It doesn’t occur on mobile responsive view, it’s just on Desktop view, when logged in the avatar disappear and where the user photo should display it displays white….and I tested the Guest Usergroup “Front – Can view avatars was already checked, and when I unchecked it the white label that was showing disappeared and didn’t show anything…

    Any more ideas?

    Thanks

    Naomi

    Plugin Author gVectors Team

    (@gvectors-team)

    Forum URL please

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WPforo Captcha Not showing in the Form’ is closed to new replies.