Support » Themes and Templates » WPFolio update made site crash

  • I updated the theme through wordpress dashboard and I now get this fatal error:

    Warning: require_once(/home/artisan/public_html/wp-content/themes/wpfolio/library/widgets.php) [function.require-once]: failed to open stream: No such file or directory in /home/artisan/public_html/wp-content/themes/wpfolio/functions.php on line 16

    Fatal error: require_once() [function.require]: Failed opening required ‘/home/artisan/public_html/wp-content/themes/wpfolio/library/widgets.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/artisan/public_html/wp-content/themes/wpfolio/functions.php on line 16

    this is my url: http://artisanofwhimsy.com/

    Could somebody please help me fix this? I’m not too knowledgable and would need detailed instructions or a step by step walk-through please πŸ™‚

Viewing 10 replies - 1 through 10 (of 10 total)
  • It sounds like an incomplete update.

    If you were updating to 1.73 (which went live yesterday) this file isn’t included: “wpfolio/library/widgets.php” nor is the reference on line 16 on functions.php. So it sounds possible that you got a partial update somehow.

    I would reinstall the theme through FTP. I can’t take the time to explain that step-by-step right now, but that’s the first thing I would do. And I’m sure you can find information online about it. If you’re really i a hurry and don’t want to learn, I would try wpquestions.com and pay someone a few bucks to handle it for you.

    Ok, I just learned what happened. Somehow it got approved with missing files.

    You can download a zip of the correct file from here:
    https://github.com/slambert/wpfolio/zipball/v1.73

    Thank you! I’ll try to upload it right away. I appreciate all the hard work going into the theme as well as the support! πŸ™‚
    Warm greetings from MΓ©xico, Claudia Liliana / rasamalai

    Oops! The download link is not working, it sends me to a blank page with this message:
    Not Found: Bad archive command for slambert/wpfolio/v1.73

    I’ve found v1.74 will that one work?

    OK, I uploaded that file and my website is back!!! ^u^ Thank you! <3

    Ah good! Yes, I had to upload 1.74 for boring reasons, but glad you’re back in action! And thanks for the kind words…

    I’m glad you did! And you’re more than welcome, I love how my website looks with your theme! πŸ™‚

    I have the exact same problem. I downloaded the map with files,which slambert posted, but do i upload the whole map or a particular file? And do I upload it through my host or through wordpress? I’m sorry, I’m not that advanced in WordPress yet. Please help πŸ™‚

    @kzantinge I’m not sure what you mean by map.

    1.74 is now live on wordpress.org. If you’re seeing errors on your site, you’ll have to update wpfolio using an ftp program (or as you put it, though your host as opposed to through the admin interface). You can download the .zip file, extract it (so it’s a set of files and folders), and upload it to the themes directory on your server. You can read about this on the codex. In your case you would be getting rid of the old wpfolio folder, and replacing it with the new one you just downloaded.

    If you find this to be too much or just want to hire someone to handle it for you, wpquestions.com is great for this kind of thing.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘WPFolio update made site crash’ is closed to new replies.