WordPress.org

Forums

WPfolio comments and 1.6 download (24 posts)

  1. kunstenaar
    Member
    Posted 4 years ago #

    I am using Wp folio 1.5.2.

    http://stephangiannini.com/

    I tried to get rid of the Comments at the bottom by following the instructions at

    http://wpfolio.visitsteve.com/wiki/getting-rid-of-comments-are-closed-message

    I changed the comments.php to ( the middle section, as )

    <?php if ( comments_open() ) : ?>
    <!-- If comments are open, but there are no comments. -->

    <?php else : // comments are closed ?>
    <!-- If comments are closed. -->
    <!--(removed for cleaner look)
    <p class="nocomments">Comments are closed.

    -->
    <?php endif; ?>
    <?php endif; ?>

    Did I do that right? Nothing changed.

    Failing that I wanted to download 1.6 and cannot find, for the life of me, where to download it. Any hints? The ever helpful Mr. Lambert?

  2. slambert
    Member
    Posted 4 years ago #

    that gets rid of the "comments are closed" message. You might be looking for this page.

    There is a list of downloads on github and, at this moment, 1.6.3 is the latest version.

  3. kunstenaar
    Member
    Posted 4 years ago #

    Thanks Again. I had already disabled the comments site-wide. But apparently all my pages had comments enabled on them. This may have defaulted to those settings when I had updated to wpfolio 1.5.2.

    Now I still have a little thing at the bottom that says "comments (0)" that I would love to get rid off.

    And In my earlier version of wpfolio, I could click through to different posts in a category. Another words I had this category page:
    http://stephangiannini.com/category/artwork/
    with four posts on it. When I clicked a post it would take me to a page with the thumbnails and a little arrow at the top that would link to the next post in the category. Which I liked. Now that is gone in 1.5.2?

    Anyway in the next day or two I will ftp up 1.6.3 and see what things get solved and what new things crop up. Thanks so much for the nce theme.

  4. slambert
    Member
    Posted 4 years ago #

    disable comments and "comments (0)" simply goes away.

    the navigation between posts appears again in 1.6.3.

    If you find the theme valuable, please consider donating. We use the $ to pay coders to develop new features.

  5. Venerated Coconut
    Member
    Posted 4 years ago #

    Help. I've disabled comments and comments are still showing on 2 pages. eg: http://erinannkoch.com/about/

    Very strange, because I'd actually like comments on "Sketchbook" but not the other 2 pages. Regardless, I'd prefer to have no comments than some comments.

    How do I get rid of them??

    Thanks!
    Cocco

  6. notlaura
    Member
    Posted 4 years ago #

    First thing - are you using 1.7? If not, download it at Github and see if the problem persists.

  7. slambert
    Member
    Posted 4 years ago #

    If the comment is already published, it wont go away. You'll need to delete it.

  8. Venerated Coconut
    Member
    Posted 4 years ago #

    There are no comments--only the option to make them. Which we don't want.

  9. slambert
    Member
    Posted 4 years ago #

    Well, if you're using 1.7 and disable comments and trackbacks, then the form goes away.

    You're using 1.5 and it's not possible with that version. I would update! Watch the first video here to learn how: http://wpfolio.visitsteve.com/wiki/instructions/set-up-wordpress

  10. Venerated Coconut
    Member
    Posted 4 years ago #

    I put 1.7 up and the comments are still showing on two pages (but not on one):

    have comment form:
    http://erinannkoch.com/about/
    http://erinannkoch.com/purchase-work/

    doesn't:
    http://erinannkoch.com/sketchbook/

    The posts, rightly, do not have the comment form.

    It's so mysterious. Any ideas?? Thanks.

  11. slambert
    Member
    Posted 4 years ago #

    turn off comments and trackbacks on those pages

  12. Venerated Coconut
    Member
    Posted 4 years ago #

    i finally just went in and deleted the comment code in page.php, as i couldn't find a turn-off option for them.

    in this version of the theme, the lightbox thumbnails have a weird border, as if the images are now too small for the frame, and it's not possible to change the main background color (at least in the theme options)?

    thanks so much

  13. varonearts
    Member
    Posted 4 years ago #

    I am having the same problem as @kunstenaar.

    I am using WordPress 3.1.2 and WPFolio 1.7.2

    I have disabled all comments and trackbacks, and I still get Comments (0) at the bottom of all my posts/pages.

    Here's the URL (setting the site up for another artist):
    http://www.laurakaretzky.com/

    I don't have this problem with my own site which is still using WPFoilo 1.5.2 - now I am little worried about upgrading: http://varonearts.org/

    Any thoughts?

  14. slambert
    Member
    Posted 4 years ago #

    Did you look through all the comments here?

  15. varonearts
    Member
    Posted 4 years ago #

    Thanks Steve, yes I checked everything before commenting here.

    I just figured it out. I had to un-check 'allow pings' before 'comments (0)' would disappear. Perhaps that was written somewhere, and I missed it?

    Thanks again.

  16. varonearts
    Member
    Posted 3 years ago #

    FYI - my solution didn't work on all the pages. Had to change the CSS to this:

    .post-bottom-title{
    margin: 5px 30px 0px;
    text-align: center;
    font-size: 0px;
    clear: both;
    }

  17. varonearts
    Member
    Posted 3 years ago #

    I have discovered another issue.

    The font size/attributes are different for Pages vs. Categories. You can really notice when looking at the letter "T" in the following:

    http://www.laurakaretzky.com/contact/
    http://www.laurakaretzky.com/category/paintings/

  18. varonearts
    Member
    Posted 3 years ago #

    Had to change the following to override this issue:

    #content h2, #content h3{
    font-weight: bold; (This was set to Normal overriding the "pagetitle")
    letter-spacing: .1em;
    }

  19. slambert
    Member
    Posted 3 years ago #

    If you unallow pings and comments on all pages, you shouldn't see anything about comments. I would check that again.

    To make elements disappear in css, rather than use font-size: 0px change the visibility

    You're right about the font weight. I never noticed that. Will make a note for the next release.

  20. slambert
    Member
    Posted 3 years ago #

    By the way, I like how nice and plain that site looks

  21. varonearts
    Member
    Posted 3 years ago #

    Thanks Steve, I don't allow pings or comments, but 'comments (0)' was still appearing. Changing the visibility works fine though.

    BTW - my own WP Folio site is also nice and plain: http://varonearts.com/

    I can't thank you enough for WPFolio - when I update my own site to the latest WPFolio version I will certainly make another donation.

    Cheers

  22. slambert
    Member
    Posted 3 years ago #

    impossible!

    You can not allow pings or comments, but they can still be enabled on posts that you created before you changed that setting. I'll bet that comments and pings are still enabled on that specific post (or posts).

    And glad you are using it. And finding problems with the CSS. And fixing them.

    I'd rather receive your fixes submitted through github than your money!

  23. varonearts
    Member
    Posted 3 years ago #

    Yeah I know about the single page override, and they have all been unchecked. You've gotta believe in the impossible!

    I'll check out github for sure.

  24. slambert
    Member
    Posted 3 years ago #

    Well, there has to be some explanation - old code? a missed checkbox? Something. The theme isn't haunted.

    By the way, I fixed the css stuff you pointed out and rolled it into the 1.75 release which should come out in the next week or so.

Topic Closed

This topic has been closed to new replies.

About this Topic