Support » Plugin: WP Extended Search » WPES takes over Woo default product search

  • Resolved arsm

    (@arsenalemusica)


    I have my search set only for a couple of custom-post-types and NOT for Woocommerce, however if I search in the shop (using Woo native widget “products search”) I get the results set by WPES. Any idea about the cause?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Sumit Singh

    (@5um17)

    Hi,

    Please share the screenshot of setting and site link to see the issue?

    Thanks

    Thread Starter arsm

    (@arsenalemusica)

    hello, you can view settings here, and shop page here. Thank you

    Plugin Author Sumit Singh

    (@5um17)

    Hi,

    Thanks for sharing the screenshots.

    This is how WPES works. You have defined not to search in product CPT in WPES global setting (global setting affect all search results on front-end) and then Woo search widget passing post_type=product in query string which is ignored by WPES because this CPT is not selected in setting.


    Solution

    1. You can include the product CPT in global settings.
    OR
    2. Disable the global setting and define new search setting for your site search (excluding product search) and use widget, shortcode, PHP to display the search form.
    OR
    3. Remove Woo search widget and create new search setting in WPES optimized for Product search then add WPES search widget.

    Let me know if you have more question.

    Thanks

    Thread Starter arsm

    (@arsenalemusica)

    What I want to achieve is to separate the widgets “global search” (on every page) and “shop search” (only if you are on shop page). I shall play a bit and will let you know…

    Plugin Author Sumit Singh

    (@5um17)

    Then you should go for #3 option.
    Sure. let me know if you need more help.

    Thread Starter arsm

    (@arsenalemusica)

    …fairly easy and resolved.
    But, on search result my site menu and footer disappear! What can be wrong?

    • This reply was modified 3 months ago by arsm.
    Plugin Author Sumit Singh

    (@5um17)

    Hi,

    This is very unlikely due to WPES. Please contact the theme support or try with default WP theme if the issue persist then let me know.

    Thanks

    Thread Starter arsm

    (@arsenalemusica)

    …this is hard to debug because if I swith to another theme my widget structures collapses and some get deleted. Also the theme author is too slow in responding. 🙁 it could be a bug in WordPress, I’m seeing many after 5.6

    Thread Starter arsm

    (@arsenalemusica)

    This is very unlikely due to WPES

    Thank you for resolving The Woocommerce search with the latest 2.0.2 update… it couldn’t possibly be blamed on my theme.

    Plugin Author Sumit Singh

    (@5um17)

    Thanks for the feedback. I am sorry I wasn’t sure it was WC template issue.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.