Support » Plugin: Comments - wpDiscuz » WPDiscuz for Pages

  • Resolved ckaden

    (@ckaden)


    Hello, just a quick question:
    I’m happily using WPDiscuz on my site, but I noticed it only shows on posts, not on pages. On pages, only the standard wordpress comment system shows up. Is this intended or a bug? Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author gVectors Team

    (@gvectors-team)

    You should turn on it in Comment Form settings. Navigate to Dashboard > Comments > Forms admin page, edit the Default Form, make sure all post types and page is enabled, save it, delete all caches and check.

    Ahhhh there it is! Thank you, I never expected it to be there.

    I also am unable to add wpDiscuz comments to pages. I have enabled the following settings:
    wpDiscuz comment form:
    – No “roles” are disabled
    – Allow guests to comment is ‘Yes’
    – Display comment form for: Post and Page is checked

    On the WordPress page that I want comments I have enabled:
    – “Allow Comments”

    Then flushed cache and did a Ctl-F5
    I am using wpDiscuz 5.0.4
    And trying to get comments on this page: https://essentialguidetocryptocurrency.com/understanding-cryptocurrency-bitcoin-101/#bitcoin-101-toc

    Are there any other settings that I might be missing?

    It turns out that the missing wpDiscuz comment box has something to do with the page “template” I choose when creating a new page. I tested the same page by changing only the template and some of my templates allow wpDiscuz comments and others don’t. The Default template did not allow comments. Now I have to figure what what it is in the default template that is causing this problem.

    I found the problem: I am using the Elegant “Extra” theme and options in that theme have an additional “allow comments” option that had to be ticked. So problem solved.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WPDiscuz for Pages’ is closed to new replies.