Support » Plugin: Comments - wpDiscuz » wpDiscuz Comment JS not properly loading

  • Resolved Mikey_

    (@mikeyuen)


    This is in regards to: https://wordpress.org/support/topic/wpdiscuz-comment-js-not-properly-loading/#post-14343615 (WP-Optimize team asked me to contact wpDiscuz). Here’s a copy of what I wrote there:

    I’ve struggled with this for some time and it only happened once in a while, but I’ve gotten to the point where I’d like to fix this. The issue affects non-logged in users and sometimes logged in users too.

    This issue appears to ONLY occur on Desktop, not Mobile, browsers.

    From time to time, the “View Comments” button does not work, rendering the entire wpDiscuz plugin unusable until the Minify and Page Caches are purged in WPO and sometimes also “Purge Everything” on Cloudflare cache. Disabling WPO fixes the issue every time, and that tells me the problem is with WPO.

    In Browser debug, it shows the following errors before I excluded wpDiscuz:
    “WP-Optimize Minify: An error has occurred in the minified code. Original script: https://…/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz.js. Error message: WpdEditor is not defined”

    I later excluded processing of JS and CSS for:
    /wp-content/plugins/wpdiscuz/assets/js/wpdiscuz-combo.min.js
    /wp-content/plugins/wpdiscuz/assets/js/wpdiscuz.js
    /wp-content/plugins/wpdiscuz/themes/default/style.css
    /wp-content/plugins/wpdiscuz/assets/css/wpdiscuz-combo.min.css

    … and turned off minify of JS/CSS within the wpDiscuz settings. The following message is shown in the browser debug:

    “Uncaught ReferenceError: WpdEditor is not defined at wpdiscuz.js:1 (anonymous) @ wpdiscuz.js:1”

    Disabling WPO plugin restores wpDiscuz functionality.

    What do I need to turn off/exclude to allow wpDiscuz to function without interference by WPO?

    Thank you for any pointers you can provide.

    I have disabled wpDiscuz for now as I cannot get it to work at all any more since the last update a day or two ago.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support gVectors Support

    (@gvectorssupport)

    Try to exclude the whole wpDiscuz /wp-content/plugins/wpdiscuz/* folder from the plugin settings.

    Thread Starter Mikey_

    (@mikeyuen)

    Thank you. I’ve excluded the following:

    Cache > Advanced Settings > URLs:
    /wp-content/plugins/wpdiscuz/*

    Minify > JS > Processing:
    /wp-content/plugins/wpdiscuz/

    Minify > CSS > Processing:
    /wp-content/plugins/wpdiscuz/themes/default/style.css
    /wp-content/plugins/wpdiscuz/assets/css/wpdiscuz-combo.min.css

    I had previously also disabled Minification of JS and CSS files and have been letting Cloudflare handle that task.

    So far, it seems to work and I’ll monitor for a week or so to see if I come across the issue again.

    Thank you again for suggesting to exclude the entire plugin instead of the individual files!

    I may remove the Caching and CSS Minify exclusions later to see if that helps speed up the site just a few more ms. My guess is that the issue only occurred with the minification of JS files

    • This reply was modified 1 year, 9 months ago by Mikey_.
    • This reply was modified 1 year, 9 months ago by Mikey_.
    Thread Starter Mikey_

    (@mikeyuen)

    Update – So far, only this setting was needed:
    Minify > JavaScript > Exclude: /wp-content/plugins/wpdiscuz/

    I removed:
    – Cache > Advanced Settings > URLs: /wp-content/plugins/wpdiscuz/*
    – Minify > CSS > Processing:
    — /wp-content/plugins/wpdiscuz/themes/default/style.css
    — /wp-content/plugins/wpdiscuz/assets/css/wpdiscuz-combo.min.css

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘wpDiscuz Comment JS not properly loading’ is closed to new replies.