Support » Plugin: Autoptimize » wpDataTables

  • Resolved OSD

    (@osd)


    I have a table (wpDataTables) running on my site but often when loading the page the table keeps loading forever.

    I noticed, after I empty the cache (Autoptimize), it’s working again for some time. I also run WP-Super-Cache….

    Does anyone have a clue how to fix this problem ?

    Richard

    • This topic was modified 2 years, 8 months ago by OSD.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    Avond Richard;
    First let me get this out of the way; something on your site is trying to block view-source and stuff, which makes it unpleasant to have to troubleshoot your site. If this is an option you can turn off somewhere somehow please consider doing so 🙂

    Now regarding wpDataTables sometimes not displaying;
    1. I see some JS errors on the browser console and although they seem unrelated to wpDataTables you might need (or want) to reconfigure Autoptimize to fix those.
    2. The probable reason for the tables sometimes not showing and that it works after clearing the cache is that wpDataTables seems to be using a nonce (a security token) that expires after x time. configuring WP Super Cache to only cache pages for for example 4 hours should fix that issue.

    hope this helps,
    frank

    Thread Starter OSD

    (@osd)

    Hoi Frank,

    Thanks for the quick response!

    I already unblocked the “view-source and stuff”, maybe you can have a second look?

    On the other hand, do I need WP Super Cache when I already running Autoptimize on my war-victims site’s… I have no idea how to reconfigure Autoptimize, there are to many conflicting examples on the net how te configure I’m afraid.

    Richard

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    still no luck re. “view source” I’m afraid.

    re. AO & WPSC; AO does not do page caching, so you need something like WPSC to do that.

    re. AO config; generic info about troubleshooting can be found in the AO FAQ. more specifically; you could tick the “also aggregate inline JS”-option, but that might cause your cache to grow (too) quickly. alternatively you could try adding
    wp-content/plugins/compact-wp-audio-player to the comma-separated list of AO’s JS optimization exclusions to fix the “ReferenceError: soundManager is not defined” error and then keep an eye out on the console for other JS errors.

    groeten uit België,
    frank

    Thread Starter OSD

    (@osd)

    Thank you Frank!

    For a matter of fact, I will remove the compact-wp-audio-player because there is no need for it with my new theme.

    After that I will keep an eye out on the console.

    vanuit Nederland,
    Richard

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘wpDataTables’ is closed to new replies.