Jetpack by WordPress.com
WPCC connection error (3 posts)

  1. Trifon
    Posted 2 years ago #

    I've tried to enable WPCC by activating the module, requesting OAuth data for a client and secret and have entered all the forms.

    But when I try to connect to my blog through WPCC, I can't get past the authorization. I keep getting "Warning! Could not confirm request token url!".
    I've looked through the settings and documentation, and the only thing that I can find which might prevent me from connecting is that the OAuth settings state that connection have to happen through HTTPS.
    My webhost doesn't allow HTTPS calls, which has caused problems for me with WP Beta Tester too.

    Is there a work-around, or can I simply not connect as long as my webhost has SSL disabled?


  2. Ben Lobaugh (blobaugh)
    Jetpack Engineer
    Plugin Contributor

    Posted 2 years ago #

    I have a host with a similar limitation. You can try forcing Jetpack to not use HTTPS by putting the following into your wp-config.php file:

    define( 'JETPACK_CLIENT__HTTPS', 'NEVER' );

    This is a quick fix, so give that a try to start with and post back on how it works. If there are still issues we will have to dig deeper.

  3. Trifon
    Posted 2 years ago #

    It doesn't seem to change anything for me. I'm still getting the same error message.

    I've just updated to 2.4.1b1 by the way. Don't know if that changes anything for this.

    ... I really am thinking about upgrading my package so that I'll have SSH capabilities. Especially since reading up on the updating discussions for Core.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.