Support » Plugins and Hacks » [WPBook ] Posts not published in my Wall

[WPBook ] Posts not published in my Wall

  • I installed the WPBook plugin aind all os ok, except two things.
    One is that my new posts are not published to my Facebook Wall, despite I have checked the option “Publish new posts to YOUR Facebook Wall” in the section “Stream/Wall Options” of the plugin.
    Can anyone help me to solve this problem?
    Thank you very much for your attention.
    Luis J.

Viewing 15 replies - 16 through 30 (of 50 total)
  • @johneckman tnx for checking, I do get this error instead of a list of friends when I click invite friends:

    Error while loading page from Vakantie huis Ameland
    Empty response received.

    Does it not work when you are the admin of the page?

    Mine works for me as the admin – though it isn’t a page, it’s an application canvas.

    Where are you clicking on the invite link – in the upper right of your application’s canvas page?

    Can you copy the link address the invite link points to?

    Mine, for example, points here:

    John, indeed it’s an application canvas not a page

    I click the invite link in the upper right:


    Well, it looks right to me, and it works for me.

    Can you ask others to try it?

    Strange, asked others and they get exactly the same problem…

    Is it maybe the fact that they, same as me, use mandatory HTTPS… in Facebook. And when using the link, which is HTTP, Facebook does not automatically convert it to HTTPS?….

    No, tried the HTTPS version of the link and same error persists….

    What can it be?

    @christianebuddy – I may or may not have been using https before, but I just tried it now.

    Application canvas page loads in https, though I do a “mixed content” warning – presumably some of the content on your blog page is not called in https – images, for example?

    When the app page is loaded in https, the link for invite friends is non-https:


    If I force that link to be https, and paste back into the browser:


    I do get the error you describe.

    Is your blog accessible via https?


    By any chance do you have access to the PHP error logs on your server?

    For some reason when called by Facebook inside an iFrame the ‘invite friends’ view is not returning data – I can try to determine what may be happening from the code, but it would be much easier if I could see the error

    @johneckman. Content is mixed (some images and external urls (twitter, facebook, some plugins) are http instead https. The whole blog is accessible through https.

    I do have access to the error logs. When you provide me with your ip and/or access time I can filter out any access, error log from you actions

    @johneckman unfortunately nothing can be seen in the logs (neither apache, nginx nor syslog) no php error occurs on the server side


    If I load the url in https *without* the fbml bit, the right code gets output:


    though of course it isn’t in FBML mode so it doesn’t display correctly.

    Adding back in the &fb_force_mode=fbml which is necessary to get the friends selector to appear the right way then throws the empty response error.

    One thing we could try. Are you comfortable editing php?

    In wpbook/theme/config.php, lines 8 and 9 read currently like this:

    $auth_url = "http://www.facebook.com/dialog/oauth?client_id="
      . $api_key . "&redirect_uri=" . urlencode($canvas_page);

    If you change that to this:

    $auth_url = $proto ."://www.facebook.com/dialog/oauth?client_id="
      . $api_key . "&redirect_uri=" . urlencode($canvas_page);

    That will then try to authenticate using https back to facebook.

    If you’re not comfortable editing php I could make a development version with the change

    Just checked in a development version with these changes.

    if you go to http://wordpress.org/extend/plugins/wpbook/download/

    you’ll see the current 2.5.2 and “other versions” – at the bottom of the “other versions” list is a development version – 15-20 minutes after I post this that dev version should have my changes and you can try that.

    Ok, I changed the php code on line 8/9. Did you change anything else? Want to know if I have to download development mode….

    The changes in php did not resolve the issue.

    Trying the development version. Does not resolve the issue….

    Thanks for trying it. The only change I had made was the one I mentioned.

    It’s odd in that it works fine without the force fbml mode (in https) or with the fbml mode (in http).

    Not sure what’s different at that point – but it seems like somehow the app isn’t getting the right user data.

    Sorry, but this one will take more time to investigate.

Viewing 15 replies - 16 through 30 (of 50 total)
  • The topic ‘[WPBook ] Posts not published in my Wall’ is closed to new replies.