WordPress.org

Support

Support » Plugins and Hacks » WPBook not posting to wall

WPBook not posting to wall

  • I have a new setup of WPBook on a site with intention to post to the site FB wall, but it does not post to the wall.

    The App is functioning and posts are visible at apps.facebook.com/etc… but post do not appear on the wall.

    I have a fully working setup of WPBook on another site and attempted to follow the same setup though it is WPB 2.0.13 and the new site is WPB 2.2.3

    It appears the setup instructions have become more confusing(or I am getting older!:)

    Under Required Settings in WPBook setup does “YOUR Facebook Profile ID:” refer to the ID of the App or the Page or the administrators personal page?

    Under Stream Wall Options in WPBook Setup does “Publish new posts to YOUR Facebook Wall” refer to the wall administrators personal page, or the Page associated with the App.

    IMO the instructions just need a tiny tweak to make these things just a little clearer.

    TIA

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author John Eckman

    @johneckman

    Note that the whole process changed dramatically between 2.0.13 and 2.2.3 – change to support Facebook’s OAuth protocol.

    When the settings say “YOUR” Facebook Profile ID they mean the administrator’s personal page.

    When the settings say “YOUR Facebook wall” they mean the personal wall of the user who is currently logged in to Facebook, who should be the person who created the app.

    In order to get permission to post to the wall of a page, wpbook needs to have a person with admin rights grant “manage pages” permission for that app.

    If you’re having trouble, first thing to do is check your “check permissions” page

    Thanks for the clarification…

    Will tweak it and try again…

    Hello

    I’ve setup WPBook for the following site http://deserthub.org but unfortunately the posts are not feeding through to the Page or Group.
    I’ve tested a few things – the app is catching the feeds, permissions seem correct, it will post to my personal wall and I’ve checked the ‘error checking’.

    The result of the latter: Caught exception in publish to group An unexpected error has occurred. Please retry your request later. Error code: 0

    I’ve retried a couple of times. No go.

    I’m sure it will be something simple.

    (now to make my WP site https proof.)

    … changed the settings on the Group, from Secret to Open, and the feed worked. No luck on the page.
    Still received the error message as above.

    Plugin Author John Eckman

    @johneckman

    Jason – what does your “check permissions” page say?

    There’s a link to it on your WPBook settings page, which should load a page in Facebook with information about what permissions have and have not been granted.

    Is the Facebook admin you’ve provided able to post to the group’s wall as a user?

    Thanks for the reply John

    Here’s the permissions view (I’ve triple-checked the various IDs too):

    FB profile * has granted these permissions:

    * offline_access – yes
    * read_stream – yes
    * publish_stream – yes
    * manage_pages – yes

    An access token for this user has been stored.

    You’ve indicated you wish to publish to this page: *

    An access token corresponding to this page has been stored.

    You’ve indicated you wish to publish to this group: *

    The user access token includes publish stream and offline access permissions.

    Plugin Author John Eckman

    @johneckman

    Without the actual IDs I can’t do much troubleshooting. Generally the issue is that the IDs are incorrect or of the wrong type.

    Do you have “Show errors posting to Facebook Stream” enabled in WPBook?

    Have you tried enabling debugging in WPBook settings?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WPBook not posting to wall’ is closed to new replies.