Support » Plugin: WPBook Lite » WPBook Lite settings page empty except "Please complete all necessary fields"

  • Hi! Upon having installed and activated the wpbook-lite plugin on my live site, when I browse in the Dashboard to “Settings” > “WPBook Lite” I see a mostly empty admin panel page as in the below-linked screenshot.

    Link to screenshot:
    https://cldup.com/yIEDloENg9.png

    As displayed in the screenshot, the admin panel page has a message at the top: “Please complete all necessary fields”. However I don’t see a long list of options, checkboxes, text fields– I don’t see the configuration controls.

    What’s a good next step to troubleshoot what’s causing(and what fixes) this symptom?

    This is on my live site. In contrast, when I install on a localhost dev site I see the admin panel page and its configuration controls as expected. In other words it seems to be something specific to my live site.

    -mjjojo

    https://wordpress.org/plugins/wpbook-lite/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author John Eckman

    (@johneckman)

    When you were on your localhost dev site, did you configure anything? Was any database configuration moved from local dev to production?

    I’ve never seen this specific problem – is there anything in your PHP error logs?

    @(John Eckman)
    Hi! Thank you for suggesting this, it led to being able to find a fix. I looked in PHP error.log file and it was putting out an error message corresponding to each time I tried to access the wpbook-lite settings page. The error message said “… Facebook needs the CURL PHP extension. …” So I installed CURL on my server and restarted apache2.

    Now I refreshed the page and I do see the “Settings” > “WPBook Lite” admin panel page, including its options, checkboxes, configuration controls etc.

    Thanks again! Lets mark this as resolved.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘WPBook Lite settings page empty except "Please complete all necessary fields"’ is closed to new replies.