Support » Plugin: Pods Beaver Themer Add-On » [wpbb post:pods_display] HTML help

  • Resolved Doug Rider

    (@riderworks)


    I’m using WordPress 4.8.1, BB Alpha 2.0 v5, Beaver Themer v1.0.2.1, Pods v2.7.0-rc-1, and Pods Beaver Themer Add-on v1.1.1. I’m unable to properly display a link using two Pods fields, “collection_url” a “Website” field and “collection_art” a “Relationship” field.

    I’m using the BB HTML module: <a href="pods_display field='collection_url']">[wpbb post:pods_display field='collection_art']</a>

    Here’s a screenshot of how it displays: https://www.dropbox.com/s/icfk93ll0q0vzy7/Screenshot%20of%20Safari%20%289-8-17%2C%2010-43-16%20AM%29.png?dl=0

    The link works, but the display is not expected. What am I doing wrong with the HTML HREF?

    Thanks.
    Doug

    • This topic was modified 3 years, 5 months ago by Doug Rider.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor Jim True

    (@jimtrue)

    @riderworks We can only support at present the currently production versions of Beaver Builder, not Alphas or Betas. We cannot and do not support issues with the Alpha/Betas as it’s not in production yet for live sites.

    We have an existing issue that is being worked on (but requires much information that just isn’t available yet from the BB developers as they are in Alpha) from our Github here:
    https://github.com/pods-framework/pods-beaver-builder-themer-add-on/issues/41

    Thread Starter Doug Rider

    (@riderworks)

    Hi Jim,

    I just reverted the BB plugin to the current release v1.10.8.1 and the issue is still the same.

    Plugin Author Bernhard Gronau

    (@quasel)

    Your code looks weird

    every call to pods should look like that
    [wpbb post:pods_display field='collection_art']

    but
    <a href="pods_display field='collection_url']">
    looks off it should be like:
    <a href="[wpbb post:pods_display field='collection_url']">

    how did you create them? by hand or using the field connection option of insert?
    alternativ you can just use pods magic tag syntax in most of the cases e.g

    [pods]<a href="{@collection_url}">{@collection_art}</a>[/pods]

    but if collection_art is an relationship field you might want to specify which field of the related pod is displayed 😉 like e.g collection_art.post_title

    Thread Starter Doug Rider

    (@riderworks)

    Hi Bernhard,

    Not sure what the “[” bracket was missing from my code. It’s shows in the HMTL module

    <a href="[pods_display field='collection_url']">[wpbb post:pods_display field='collection_art']</a>

    I also tried the PODS magic tag syntax and that doesn’t work either. Since ‘collection_art’ is a Relationship field, I changed it to ‘collection_art.post_title’. But that didn’t work either.

    I’ll take this up with Beaver Builder support.

    Thanks.
    Doug

    • This reply was modified 3 years, 5 months ago by Doug Rider.
    Plugin Author Bernhard Gronau

    (@quasel)

    Your code is still wrong …. take a closer it’s still missing the string wpbb post:

    a link to the site always help’s too – for faster resolve you can join our Slack https://pods.io/chat too

    Bernhard

    Thread Starter Doug Rider

    (@riderworks)

    Sorry, I’m having a hard time dealing with the code tag. This is the code that’s being used.
    <a href="[wpbb post:pods_display field='collection_url']">[wpbb post:pods_display field='collection_art.post_title']</a>
    This is a testing site. I’ve white listed the post where you can see the display. I’m using Beaver Themer. https://beartproject.staging.wpengine.com/art/metamorphosis/

    • This reply was modified 3 years, 5 months ago by Doug Rider.
    Plugin Author Bernhard Gronau

    (@quasel)

    From looking at the sites source code it seems you have activated the option: “Output as link?” in admin -> edit pod -> Additional Field Options

    as a result the first part is output as link itself and the code transforms to

    <a href="<a href="https://beartproject.staging.wpengine.com/collection/high-school-2015/">https://beartproject.staging.wpengine.com/collection/high-school-2015/</a>">High School 2015</a></div>

    which obviously can’t work due to wrong syntax!

    Thread Starter Doug Rider

    (@riderworks)

    Hi Bernhard, thank you so much. I just removed the “Output as link” for the website field and now it’s working.

    • This reply was modified 3 years, 5 months ago by Doug Rider.
    Plugin Author Bernhard Gronau

    (@quasel)

    You’re welcome! The best way to say thanks is to leave a 5 star review at https://wordpress.org/support/plugin/pods-beaver-builder-themer-add-on/reviews/#new-post *and* (if you’re feeling especially generous) become a Friend of Pods at https://pods.io/friends-of-pods/

    Glad we could solve your issue!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[wpbb post:pods_display] HTML help’ is closed to new replies.