Support » Plugin: WordPress Popular Posts » WPBakery Post Grid with WPP not working with WPML

  • Hello.

    I am using the custom code from this thread to display most popular posts on my page: https://wordpress.org/support/topic/show-popular-posts-with-wpbakery-post-grid/

    Within WPBakery post grid, I am using the “offset” setting for each post grid because I have three post grids per section stacked atop one another. The first grid is set to nothing, then 1, then 2. In conjunction with “views_daily” or any other meta key setting (views_weekly, views_monthly) works beautifully with the English version of my posts.

    However, the translated versions (see French as my test sample) does not work at all, regardless of the meta key I choose. And when something does display, it seems to be based on publication date, not page views.

    I have combed your support pages and have not seen this specific situation replicated. Please let me know if you can help.

    English page:
    https://marketing.istockphoto.com/

    French test page:
    https://marketing.istockphoto.com/fr/blog-istock-testing/

    My setup:
    WP 5.4.2
    Jupiter Child Theme (up to date)
    WPP, WPML, and WPBakery are all up to date as of today.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Héctor Cabrera

    (@hcabrera)

    Hi @pgweis,

    As you know WPBakery is a paid plugin. Unfortunately as I don’t have a copy of it nor a valid license (nor I intend to buy one just for testing) I can’t really help you debug/test WPP with WPBakery as I’d like to.

    With that being said, I noticed that you’re also using the W3 Total Cache plugin on your website and so your problem is likely a caching issue: keep in mind that W3 Total Cache will cache everything on page for a fixed period of time. During that time nothing on your website will be updated -including your popular posts list- except features/contents that are loaded via AJAX. And as far as I can see it doesn’t seem that you’re loading your popular posts section via AJAX.

    This explains why, for example, your popular posts list looks so different in both languages (as in showing different posts) right now:

    WPP in English and French

    This is probably why you feel that WPP doesn’t work “at all” sometimes.

    Thanks for the quick response. I have tried clearing the cache and not seen a difference, but will look into the Ajax issue.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.