WordPress.org

Support

Support » Plugins and Hacks » [Resolved] wpautop not working

[Resolved] wpautop not working

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author WebTechGlobal
    Participant

    @webtechglobal

    No one has raised this before but it does sound like something may need done. Looking into it now.

    I’ve never worked with the wpautop function so have a little reading to do. From what I do know, it should be applied automatically because it is on by default and there are plugins for disabling it.

    Can’t see CSV 2 POST disabling it so I’m thinking WordPress applies paragraphs to content prior to calling wp_insert_post() which creates the entire post.

    Plugin Author WebTechGlobal
    Participant

    @webtechglobal

    I may be mistaking about the functions use after reading this…

    wpautotop

    How, where and why are you using wpautop?

    The CSV file I am trying to upload is without paragraphs or line breaks.

    Plugin Author WebTechGlobal
    Participant

    @webtechglobal

    Most users import one paragraph of text (no actual <p> though) or they import content with
    and <p> in it. It is possible others have had the same problem as yourself but not reported it.

    Not sure if other importers put content through wpautop() function by default but I think we’ll need a setting in CSV 2 POST to disable/enable it.

    I will get it done this week and return to this post with an update. Thank you for your feedback.

    Plugin Author WebTechGlobal
    Participant

    @webtechglobal

    Hello again.

    Today I added a setting on the Content screen in Projects for activating wpautop(), in the paid edition.

    Do you require it in the free edition? Was not sure if you had purchased the plugin or not.

    Ryan

    I am using the free edition.

    wpautop is a filter that WordPress applies to all content at the time the content is displayed. It converts newlines to
    and double newlines to <p>…</p>.

    It is applied unless the theme author turns it off in their functions file. I do that frequently to keep it from messing with markup.

    If you are not getting paragraphs the content does not contain newlines. Possibly this is an issue between the various flavours of newline cr, lf, and crlf that vary with operating system.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] wpautop not working’ is closed to new replies.