Support » Plugin: Yoast SEO » wp_yoast_seo_meta bloat

  • Resolved lauratraveler

    (@lauratraveler)


    Hi,

    I have a few dozen posts and pages and thousands upon thousands of entries in the wp_yoast_seo_meta table. The vast majority of these entries (maybe 99%) of them show a value of 0 (zero) under both internal link count and incoming link count column. What’s generating all these thousands of entries in this table? Can this table be cleaned? It’s one of my biggest tables and I don’t see any reason for it to be this big.

    The wp_yoast_seo_links table, on the other hand, has hundreds if not thousands of links that although I might have used at one point in my posts and pages, I since then removed them from the site. How can I delete these old links that serve no purpose anymore?

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    Are you using the free or premium Yoast plugin? If you are using the Premium one please send us a ticket to support@yoast.com. That way we can review the account settings and investigate the issue.

    If you are using the free plugin, let us know the following

    1. Can you confirm you are using WordPress 5.3.2? You can check by clicking on the W in the top left and selecting About. If you need to update, please check with your host provider. Please know that if you are using an older version of WordPress Core you may experience unexpected behavior with Yoast. This guide explains more: https://yoast.com/why-we-dont-support-old-wordpress-versions/.

    2. Can you confirm you are using the most recent Yoast SEO, v13.1? If you update, does the issue resolve?

    3. Can you confirm your server has all the right requirements?  If you are not sure, speak to your host provider. They may need to increase the PHP memory. This guide explains more: https://kb.yoast.com/kb/plugin-requirements/.

    Thread Starter lauratraveler

    (@lauratraveler)

    Hi @pcosta88
    Yes, I’m using the free plugin and have WordPress 5.3.2 with Yoast SEO v13.1.
    Server PHP version is 7.4, MariaDB version greater than 10 and PHP memory of 256M.

    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    Our developers indicate that you should use the filter listed here https://github.com/Yoast/wordpress-seo/pull/12751 to disable it.

    Unfortunately, there’s a difference between the support we can offer and the level of programming needed to change (core) features of our plugin. Since we don’t want to take the risk that we break your website by suggesting incorrect or incomplete code, we cannot advise you on how to make such changes. And even though we cannot be of any assistance, you’re completely free to change anything in the plugin to better suit your needs.

    We highly recommend checking out our list of Yoast Partners here https://yoast.com/yoast-partners/ in case you are in need of development.

    We will also keep this issue open for 2 weeks in case someone from the community can help. Perhaps a developer watching these forums can assist further. After which, we will close in order to keep the overview.

    Plugin Support amboutwe

    (@amboutwe)

    This thread has been marked as resolved due to a lack of activity.

    You’re always welcome to re-open this topic. Please read this post before opening a new request.

    Thanks for understanding!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘wp_yoast_seo_meta bloat’ is closed to new replies.