wp_tiny_mce anchor issue (5 posts)

  1. fjpalawan
    Posted 4 years ago #

    Hi Everyone,

    Im calling tinymce on my plugin using this code

    wp_tiny_mce( true ,
    "editor_selector" => "broadcastmessage",
    "height" => 300,
    "width" => 300

    but im having issue in his anchor button. its not working. Other buttons are working fine.

    I tried it on 3.0.1 and its working fine.

    Any help would be much appreciated from you guys.

    Thanks a bunch!

  2. Danny van Kooten
    Posted 4 years ago #

    Same problem here. Did you figure it out yet? Anyone? I noticed the WPlink script, although it's still not working when I enqueue that.

  3. abelony
    Posted 4 years ago #

    I don't know if it's related but maybe this will help.

    if (function_exists( 'wp_tiny_mce_preload_dialogs' )){
                 add_action( 'admin_print_footer_scripts', 'wp_tiny_mce_preload_dialogs', 30 );
  4. Danny van Kooten
    Posted 4 years ago #

    Yeah Abelony, that should do it! Figured it out in the meantime, thanks though!

    Check out "Using TinyMCE in your WordPress plugin" on my blog for more info.

  5. abelony
    Posted 4 years ago #

    Cool Danny.

    It took me 3 hours to finally figure this out when wp 3.0 came out. All of a sudden it stopped working for a plugin that I was working on. Another issue that I have seen is that when there is a non wp standard jqueryui component (e.g. datepicker) being loaded on the same page, this dialog inherits the styles from thickbox and jqueryui css and looks a little "broken". There are two X buttons for closing, the header gets the jqueryui color instead of being black. Still haven't figured that out.

    Very nice and easy to follow post on your blog.
    :) Love WP, Codeigniter, and jQuery, too.

Topic Closed

This topic has been closed to new replies.

About this Topic