Support » Installing WordPress » wp_terms’ doesn’t exist – Fixes here don’t work – HELP Please

  • None of the solutions to the horrible — wp_terms’ doesn’t exist — problem here work.

    1. Forced upgrade via phpmyadmin or wp-admin/options (manually setting db_version number back and re-running upgrade script) has no effect.

    2. Yes, I can go to a back up and roll to previous WP version, still doesn’t help me get to latest version though..right?

    Can the kind folks at WordPress please help us thousands of bloggers who now have ugly blogs with errors all over them thanks to this bug? Also –a little advance warning next time (Warning: This will blow up your blog) would be nice. Sorry to sound so frustrated, but everyone who posts this problem is getting the same answer and none of the fixes work. I’ve tried them.

    Any NEW solutions from someone who has been there?

    BTW… check this google search if you’re wondering how many blogs show up with this error.

Viewing 8 replies - 1 through 8 (of 8 total)
  • So do you have the tables wp_terms, wp_term_relationships, and wp_term_taxonomy in your database?

    If not, then that would suggest the upgrade.php did not complete successfully.

    That’s the thing… I did the upgrade (which “said” it was successful) and then had the errors. Then I tried the force upgrade of the db so that I could make WP run the upgrade script again (otherwise you get the message that the upgrade already ran fine).

    No matter what I do — WP tells me everything went fine yet the appropriate tables do not show up on my database when I check it in phpmyadmin.

    Has anyone come up with a fix for this? Judging by the amount of blogs out there with these errors on the page, I think this would make for a good step-by-step sticky.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    Has anyone come up with a fix for this?

    There’s only one way to fix this. Restore your backup and then perform the upgrade again, only this time, make sure it works correctly.

    The only reason it won’t work is because it cannot modify your database for one reason or another. This may be because you did it on a live in-use database, or because you don’t have the correct permissions in MySQL to modify the tables, or the phase of the moon, or half a dozen other reasons.

    But regardless of all that, there is only ONE POSSIBLE FIX. The upgrade was NOT successful. So restore from a backup and try again. If it continues to be unsuccessful, try to figure out why it’s unsuccessful.

    The upgrade process is not “buggy”. It works perfectly if the database does what it’s told to do. But when it doesn’t do that, then naturally it doesn’t work.

    I’m rolling back to the old version. I’ve already done the upgrade SEVERAL TIMES and you do not get ANY errors. There is no sign anything is wrong until you look at your blog and/or the db tables.

    Not to be cheeky, but if this was just something I happened to do wrong (and I’ve updated a lot of php programs, although I don’t pretend to be an expert) do you think you’d see 20,000+ google results when you search for this error?

    I’m sorry…. but I think that whilst there are still tons of messed-up blogs out there, it is reasonable to suggest that there might be something amiss.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    There is no sign anything is wrong until you look at your blog and/or the db tables.

    Of course not, the upgrade process has no way to determine whether the upgrade was truly successful or not. If the database fails to do what the upgrade process tells it to do, then there’s nothing that can be done about it except to fix the database.

    if this was just something I happened to do wrong

    You’re misunderstanding. I didn’t suggest that you did anything WRONG. I’m suggesting that you’re a victim of circumstance. Something is wrong with your database setup. It’s not allowing you to perform the upgrade properly. You would have had this same problem on virtually any major WordPress upgrade, really.

    But we can’t tell you what’s wrong with your database. We don’t know what’s wrong with your database, because it’s your database. So we’re in a very poor position to help you solve your problem.

    See our dilemma here? I have encountered the problem myself, corrected my own permissions, and got on with life. But I can’t tell you how to do that, because how you do it will be different from how I do it. You may not have control over your database to begin with if you’re paying somebody for hosting. So really, you kinda have to talk to them, make sure that the user has full permissions. Or use phpMyAdmin to fix the permissions. Or something else. Whatever you do to fix the problem will be outside of WordPress and somewhat out of the expertise we can provide here on this forum.

    The database is just one of those things that’s outside of the scope of WordPress. You have to create it yourself before you can install WordPress. So it’s not something WordPress really controls to any great degree. It uses it, it does not own it.

    One thing I will say is that this most often happens when you use “automated” type installation systems. If you create your database yourself and install WordPress yourself, this problem almost never crops up. But automated installers often break things.

    Just wanted to point out that I had the same problem. I did some looking around the code and some debugging and turns out my FTP crapped out half way through updating the wp-admin folder, so when I went to run the upgrade process half of the files were updated so it was correctly returning the version number, but the wp-admin/includes/ folder (which included the schema.php file) was missing so it didn’t have anything to properly upgrade to.


    Oh yea, almost forgot. In order to rerun the upgrade process after you’ve done this you’ll need to open up the wp_options table in phpMyAdmin and look for the ‘db_version’ option and change the option_value from 6124 to what it previously was in your backup. That should properly fix the everything for you.


    Thanks Ryan, I tried that. Didn’t work for me, but I understand it does work for others.

    I understand the mod’s point that any number of things can cause an upgrade to go wonky –and I agree. Also agree that problems can be avoided with by doing things without auto installers.

    After spending more time than I wanted to, I decided to go back to the old version, which was good enough for me.

    I still say, it’s something WP should think about. For example, when I checked last, Google came up with over 23,000 returns for the error. Now, let’s say most of those are just discussions. So maybe only 3,000 blogs have that error. Still a lot, right?

    Now, each could have it for a different reason, but isn’t it odd that so many blogs have the same error? And why aren’t the tables being updated?

    I’m not complaining about wordpress, which I quite like, only saying that enough people are having this one particular error (for whatever reasons) that it’s probably worth it for the developers to look into it ahead of the next release.

    In any event –many thanks to everyone for taking the time to help.

    See you all in the next version.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘wp_terms’ doesn’t exist – Fixes here don’t work – HELP Please’ is closed to new replies.