WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] wp_tag_cloud ignores “exclude” parameter

[Resolved] wp_tag_cloud ignores “exclude” parameter

  • Hi.

    I’m running WordPress 2.3 and trying to create a tag cloud, everything is ok with the tags, but the function wp_tag_cloud seems to ignore the ‘exclude’ parameter.

    wp_tag_cloud(“smallest=8&largest=25&unit=px&number=15&exclude=512-links”);

    I tried with some others tags but nothing works. Allways showing all the tags (or the 15 tags as indicated by the number param)…

Viewing 8 replies - 1 through 8 (of 8 total)
  • MichaelH

    @michaelh

    So 512-links is the name of the tag you want excluded?

    MichaelH

    @michaelh

    Yeah, I can’t get the include or exclude parameter to work.

    MichaelH

    @michaelh

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    The include and exclude parameters should only take ID numbers of the entries in the taxonomy table (comma separated), not slugs or names or anything else. Looking through the code, it should work fine, as far as I can tell.

    And am I the only person whom trac is not working for anymore? It sits there and never loads.

    MichaelH

    @michaelh

    Okay, set that ticket to invalid in Trac and will update Codex Template_Tags/wp_tag_cloud.

    Thanks Otto. Trac is working for me 😉

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    Well what the hell? I can’t get trac to work at all. It just eventually gives me “Operation timed out”. This sucks! 🙁

    thanks… problem solved

    I am having the same problem:

    wp_tag_cloud(‘smallest=8&number=40&exclude=230’)

    230 is the tag_id from the wp_tags table. That is where I get the number from, right? But it’s not working. I can change all other parameters except exclude.

    I am losing my mind on this one.

    Thanks for any insight.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] wp_tag_cloud ignores “exclude” parameter’ is closed to new replies.