Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » WP_Scripts::localize was called incorrectly.

  • Resolved Venus10

    (@venus10)


    I get this error thrown on the backend with wp 5.7:

    WP_Scripts::localize was called incorrectly. The $l10n parameter must be an array. To pass arbitrary data to scripts, use the wp_add_inline_script() function instead…public_html/wp-includes/functions.php on line 5313 which I traced down to nextgen gallery plugin.

    And this causes also that the site is partially crashing, means only side bars are visible but the pages don’t show up.

    Any solution or fix on the way already ? Saw this error with other plugins as well after upgrade to wp 5.7.

Viewing 2 replies - 1 through 2 (of 2 total)
  • In this file:

    wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/attach_to_post/module.attach_to_post.php

    Comment out 424-428, they use it incorrectly.

    (Thanks mod for removing our comments, the other had the solution, we do actually have the same problem…)

    • This reply was modified 3 months, 4 weeks ago by Firsh.
    Plugin Support mihai-imagely

    (@mihaiimagely)

    Hi @venus10,

    This should be fixed since NextGen Gallery 3.9.2. We hope that you wouldn’t mind updating to the latest version of NextGen Gallery to resolve the warning.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.