Support » Plugin: Orbit Fox by ThemeIsle » WP_Rest_Controller

  • Resolved private_tank

    (@private_tank)


    I updated the themisle-companion and got this error.

    Fatal error: Class ‘WP_Rest_Controller’ not found in /home/xxxxx/xxxxxxxx/wp-content/plugins/themeisle-companion/vendor/codeinwp/themeisle-content-forms/class-themeisle-content-forms-server.php on line 9

    Using php 7.0 any ideas

    Theme- Zerif Lite!

    • This topic was modified 3 years, 6 months ago by private_tank.
    • This topic was modified 3 years, 6 months ago by private_tank.
Viewing 11 replies - 1 through 11 (of 11 total)
  • Hi,

    Can you let us know what version of WordPress are you using?
    WP_Rest_Controller was introduced in 4.7.0 so you will need at least this version for this plugin to work.

    Thread Starter private_tank

    (@private_tank)

    WordPress 4.6.1.

    • This reply was modified 3 years, 6 months ago by private_tank.
    Thread Starter private_tank

    (@private_tank)

    Thank you I had a plugin blocking the automatic update from evening showing.

    Hello the same thing happens to me and I finished updating now and everything has fallen down, I am not an expert and I do not know what to do I can not enter anything.

    Fatal error: Class ‘WP_Rest_Controller’ not found in /home4/macpelli/public_html/adonatolahiguera/wp-content/plugins/themeisle-companion/vendor/codeinwp/themeisle-content-forms/class-themeisle-content-forms-server.php on line 9

    Thread Starter private_tank

    (@private_tank)

    Deactivate all your plugins, see if you can update your site. Update your site. Then turn on each plugin one at a time to see if you site works after each one.

    • This reply was modified 3 years, 6 months ago by private_tank.
    • This reply was modified 3 years, 6 months ago by private_tank.

    I can not even access the administrator, If I wanted to do it by cpanel, how could I disable the plugins, temporarily changing sites?

    Thread Starter private_tank

    (@private_tank)

    Ahh the site is crashed

    Ok here is what you do

    1. Log into cpanel
    2. Navigate to files manager
    3. Navigate to this folder public_html/wp-content/plugins
    4. Rename the folder themeisle-companion – something you want
    5. Log back into you wordpress admin
    6. Once everything is working and updated, put folder themeisle-companion back to its original name
    7. Reactivate themeisle-companion plugin
    Let me know

    • This reply was modified 3 years, 6 months ago by private_tank.
    • This reply was modified 3 years, 6 months ago by private_tank.
    • This reply was modified 3 years, 6 months ago by private_tank.
    • This reply was modified 3 years, 6 months ago by private_tank.

    Thank you very much, it was perfect, really thank you very much for your quick answers, I won you a beer

    Te invito a una cerveza amigo

    Thread Starter private_tank

    (@private_tank)

    No problem glad i could help.

    Tried following the steps above but my plugins folder doesn’t even have a themeisle-companion folder.
    Also tried renaming my plugins folder as suggested in other posts and manually updating WP (since my dashboard is inaccessible) without success. What else can I do?

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘WP_Rest_Controller’ is closed to new replies.