Support » Plugin: Wordfence Security - Firewall & Malware Scan » wp_remote_post() test back to this server failed! Response was: 404 Not Found

  • Resolved insightdes

    (@insightdes)


    Hi Folks,

    We can’t perform a Wordfence scan.

    In the Diagnostics screen, we see a red message:

    wp_remote_post() test back to this server failed! Response was: 404 Not Found

    How do we resolve this please?

    Thanks,
    Steve

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi @insightdes!

    Where it says “wp_remote_post test failed” there should be a link to view details. This would expand to show the full contents of the 404 page that was served. That might help you figure out why it’s happening.

    You also might want to check what happens if you just try visit admin-ajax.php in a browser to make sure this file hasn’t gone missing.

    I think I can tell you this because I have the same problem.

    What happens if you visit admin-ajax.php? You get a “0” which means it is working.
    However, if I do the same with curl on the server, I get a 404 error.

    This happens regardless of whether or not I activate or deactivate Wordfence on the site.

    Maybe you should write your own handshake, because it seems like this is a MAJOR ISSUE for a lot of people!

    • This reply was modified 1 year, 3 months ago by ppehrson.

    Hi @ppehrson,

    We use WordPress core functionality for this which is the recommended way of doing things for compatibility. I don’t think it’s an issue we hear about specifically often. However, I understand it’s a problem for you currently.

    If you are getting a 404 on admin-ajax.php via cURL or when not logged in to WordPress admin it likely means you have some code in your WordPress installation which is causing this. It is not normal behavior.

    For further testing you can use the WordPress core functions wp_remote_get and wp_remote_post which is what Wordfence is using.

    https://codex.wordpress.org/Function_Reference/wp_remote_get
    https://codex.wordpress.org/Function_Reference/wp_remote_post

    Try deactivating all other plugins but Wordfence as well. That way you may be able to narrow down which one is causing it.

    Plugin Support wfdave

    (@wfdave)

    Hi @insightdes,

    We haven’t heard back from you in a while so I’ve gone ahead and marked this thread as resolved.

    if you’re still having issues with Wordfence, please feel free to open another thread.

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘wp_remote_post() test back to this server failed! Response was: 404 Not Found’ is closed to new replies.