wp_posts.MYI ??? (3 posts)

  1. pixellated
    Posted 11 years ago #

    We're getting the following error(s) on our front page:
    Database error: [Can't open file: 'wp_posts.MYI'. (errno: 145)]
    SELECT DISTINCT * FROM wp_posts LEFT JOIN wp_post2cat ON (wp_posts.ID = wp_post2cat.post_id) WHERE 1=1 AND (category_id != 2) AND post_date_gmt <= '2004-11-22 18:46:59' AND (post_status = "publish") GROUP BY wp_posts.ID ORDER BY post_date DESC LIMIT 15
    Database error: [Can't open file: 'wp_posts.MYI'. (errno: 145)]
    SELECT DISTINCT YEAR(post_date) AS year, MONTH(post_date) AS month, count(ID) as posts FROM wp_posts WHERE post_date < '2004-11-22 13:46:34' AND post_status = 'publish' GROUP BY YEAR(post_date), MONTH(post_date) ORDER BY post_date DESC
    I've never heard of file 'wp_posts.MYI' ... what is this, what's happening, and how can we fix it? Thanks!

  2. pixellated
    Posted 11 years ago #

    Found out that, for whatever reason, it has something to do with changing the post content fieldtype from TEXT to LONGTEXT (as someone in another thread suggested doing for extra-long posts)... apparently, while it works for some people, it caused MySQL on our host to go completely berzerk and give the errors above.
    After we were able to log back into PHPMyAdmin and change the content fieldtype back to "TEXT" and the host ran a repair on MySQL, everything worked fine. We actually tried doing this several times, and each time, the host had to run a repair on MySQL... so we're not touching the field types anymore, and the site owner will just have to be less verbose in the future! ;)

  3. likoma
    Posted 9 years ago #

    Thanks for this. I did a "check" my PHP MyAdmin for the SQL DB and saw some error, so I did a "repair" and it fixed it and now all is working. Hmm, so a really long post did this? The posts aren't that long. Hmm.

    Thanks again for posting this.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.