Yet Another Related Posts Plugin (YARPP)
[resolved] wp_posts table engine issue (10 posts)

  1. Arley McBlain
    Posted 2 years ago #

    I recently moved a dev site from an IIS server (don't ask) to a proper Apache server. Naturally I had the InnoDB error, so I changed all of the tables to MyISAM, but YARPP is still not working perfectly. Now I have the error:

    YARPP's "consider titles" and "consider bodies" relatedness criteria require your hmp_posts table to use the MyISAM storage engine, but the table seems to be using the 1 engine. These two options have been disabled.

    Not sure what the "1" engine is!

    Curiously I have a terrible hack working... if I inspect element on the Consider Titles and Consider Bodies fields, remove the Read Only / Disabled restrictions and choose these, then save - it works. But if I want to change any other settings I have to do this hack every time! haha.

    Any idea what needs to be done here?


  2. Arley McBlain
    Posted 2 years ago #

    I have removed the two YARPP tables, and reinstalled the plugin, and have run http://mitcho.com/code/yarpp/sql.php but I still get the "1 engine" error as above. Another symptom is that my hack doesn't let the custom PHP template I made work!

    Any ideas? About to throw in the towel and try to find another related post plugin that allows for custom templates!

  3. Arley McBlain
    Posted 2 years ago #

    How does one totally uninstall YARPP? Maybe I didn't do that right?

  4. mitcho (Michael Yoshitaka Erlewine)
    Plugin Author

    Posted 2 years ago #

    Hmm, since you're on LAMP now, I assume this is a MySQL server?

    What version of YARPP are you using?

    One thing you might want to try is to completely reset YARPP's settings. In the wp_options table, find the options containing the word "yarpp" and delete them.

  5. Arley McBlain
    Posted 2 years ago #

    Boom! Yeah, that was it. Once I deleted the entries in wp_options as well and reactivated the plugin the problem was solved.

    I vote you make the uninstall process a FAQ.

    Thanks for the support!

  6. mitcho (Michael Yoshitaka Erlewine)
    Plugin Author

    Posted 2 years ago #

    Glad that worked. Sorry that happened in the first place, though. I'll look into it.

  7. Arley McBlain
    Posted 2 years ago #

    Before you start troubleshooting migration from IIS I'm sure there are lots of better things WordPress devs can do. Like smell a flower, or alphabetize the contents of their fridge!

    Thanks for your awesome dedication!

  8. myownprivate
    Posted 2 years ago #

    Same here. And I followed your instruction, but it didn't work. Then I realized I didn't deactivate some cache stuff. Right after turning them off, Boom <3

    Thanks both of you!

  9. rtpayne44
    Posted 2 years ago #

    I recently had to rebuild my wp_posts table and ran into the MyISAM storage engine issue. Uninstalling, deleting YARPP wp_options entries and reinstalling did the trick. Straight life savers, thank y'all!

  10. Paul Thomson
    Posted 2 years ago #

    For google'ers,

    If you're running memcached or apc you'll need to find and delete the database tables via mysql using the following (or similar command):

    SELECT * FROM wp_options WHERE option_name LIKE "yarpp%";

    delete all you find.

    Then restart the services:

    sudo service memcached restart && sudo service php5-fpm restart && sudo service mysql restart

    Thanks for this post, I hope this helps some of you out there...

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yet Another Related Posts Plugin (YARPP)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.