Support » Plugin: Paid Memberships Pro » wp_pmpro_memberships_users and wp_users not linked

  • Resolved diondkb

    (@diondkb)


    Hi,

    When I receive a new member via paypal or stripe, an entry appears in the wp_users table as well as the wp_pmpro_membership_orders table, but they are not linked. The wp_pmpro_membership_orders table has the entry without the user_id and the wp_pmpro_memberships_users table does not have an entry at all. There does not seem to be an issue with the webhook. Any ideas why this is happening would be appreciated.

    Regards.
    Dion

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Andrew Lima

    (@andrewza)

    Hi Dion,

    Thank you for using Paid Memberships Pro.

    The pmpro_memberships_users should populate the user_id field with the WordPress user ID.

    When a user signs up for a membership level, are they receiving a membership level or is it not getting assigned to the user?

    Hi Andrew,

    As stated above, they do not have an entry in the wp_pmpro_memberships_users table and thus their entry in the wp_pmpro_membership_orders table does not have a user_id value. I have to keep doing this manually!

    Plugin Author Andrew Lima

    (@andrewza)

    Thanks for the feedback, I’d recommend in running this in a staging / testing environment and have a backup on hand before running any tests.

    It’s difficult to speculate what is causing this, as it’s a site-specific issue.

    You can try the following:

    Temporarily disable all your plugins except Paid Memberships Pro core, and run a checkout with a new user to see if the issue persists. If it doesn’t, then there is a conflict with a plugin. You can reactivate one plugin at a time and retest your checkout, the last plugin activated that made the checkout fail is the culprit.

    You may also enable debugging in WordPress by following this guide – https://www.paidmembershipspro.com/how-to-enable-debugging-on-you-your-wordpress-site/

    Please let me know if there are any errors in your debug.log.

    Thank you for your patience and understanding.

    • This reply was modified 7 months, 1 week ago by Andrew Lima.
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘wp_pmpro_memberships_users and wp_users not linked’ is closed to new replies.