Support » Plugin: Facebook for WooCommerce » wp_options > wc_facebook_google_product_categories

  • Resolved patrickhs

    (@patrickhs)


    We started having a ton of 503 errors on the backend of our website so I opened a support ticket with our host. They evaluated our site and this was a significant factor in their response: “The database’s options table is a bit bloated and could use optimizing and the Autoload in your database is a bit large at 1.21MB.”

    So, when looking at wp_options I see that wc_facebook_google_product_categories is approximately 0.71MB of the total 1.21MB being used. How can we optimize this plugin to get rid of the issue rather than having to get rid of the plugin?

    We’re using plugin version Version 2.1.4 on WooCommerce 4.7.0 – PHP Verion 7.4.3

    Thanks!

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • I have same question too!.

    thanks

    J

    P.s for 503 errors ,get the Heart Beat Plugin it helped.

    • This reply was modified 1 month, 4 weeks ago by kattouf.

    Same here. Discovered this auto load row is 708,649 characters long. Perhaps the most oversized row I’ve ever come across.

    same here with 708,649 lenght

    • This reply was modified 1 month, 3 weeks ago by alezucchi.

    Considering the importance and especially as we’re going into a holiday weekend critical for eCommerce, I’ve opened this up on GitHub as well here:

    https://github.com/facebookincubator/facebook-for-woocommerce/issues/1708

    same here and autoload size is going skyrocket du to facebook plugin ( 1mb)

    Plugin Support simonskyverge

    (@simonskyverge)

    Hi all!

    Thanks for raising this issue, and thanks for the feedback so far. The option was created for the Google Product Category implementation, to allow specifying this for your synced products to help avoid errors in Commerce Manager and allow for better ad creation.

    The list of categories itself is causing this to be a large option value as you’ve seen. We’ve raised this with our developers to see what improvements we can make to the implementation to avoid these types of issues going forwards, sorry once again for the problems this is causing!

    While there isn’t a fix for this in the short term, it would be possible to revert back to plugin v2.0.5, before the categories were added, and remove the database option.

    I’m sorry this isn’t the best news at this time! Is there anything else I can help out with?

    Cheers,

    Simon.

    Plugin Support John Coy

    (@johndcoy)

    Automattic Happiness Engineer

    If a developer would like to contribute to the plugin to help with this optimization please use the GitHub repository to do so:

    https://github.com/facebookincubator/facebook-for-woocommerce

    I migrated another client who uses this plugin over to WP Engine. The onboarding tech there informed me I needed to delete or de-autoload this particular wp-option before I could enable their Object Caching feature (Redis). There was one more problematic row from the official Woo CSV importer plugin I’ll open-up with them. I switched this to autoload=off and it fixed the WP Engine Redis issue. Still, it’s an oversized row with potential to hit limits on certain environments.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.