Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » wp_options to many records

Viewing 15 replies - 1 through 15 (of 38 total)
  • I noticed that too, it is not good.

    Nextgen, I believe this is a critical issue hat has to be looked into with top priority as it will eventually bring everything to a halt.

    Added to crontab
    DELETE FROM wp_options WHERE option_name like '_transient_%' OR option_name like 'displayed_galleries%'

    Thanks for that info, important when we update later to the future stable nextgen, just in case nextgen ignores this issue (unintended, or deliberately because their new program depends on consuming resources)

    I have the same issue. I get up to 20k new records daily in options table also table is not optimized, for queries like WHERE autoload = ‘yes’ no index on autoload column so with 50k records options table is huge performance hit.

    Plugin Author photocrati


    Hey all – we do make use of transients for various things in NG 2.0. Those should be flushed periodically, and regardless I’m surprised at the numbers being reported above. We’ll take a look at this.

    For now, I’m wondering if when you see this, you can please trying to go Gallery > Other Options > Miscellaneous and click “Clear Image Cache” and let us know what impact that has?

    When I click “Clear Image Cache” nothing happens. Nothing is flushed at DB.
    As before, every hour use the query (crontab)

    DELETE FROM wp_options WHERE option_name like '_transient_%' OR option_name like 'displayed_galleries%'

    “Clear Image Cache” works for me, but the problem is widget. I had widget with 8 pics on every page, so it creates over 5k records in an hour , so creal cache is not reliable in this situation.

    Hi, I have encountered the same problem. I’ve installed 2.0.0 version of plugin.
    MySQL DB of my web site is more than 180 mb because the table wp-options. I’ve removed NextGen Gallery widget and DB has stopped growing. Now I’d like to clean up the DB and the wp-options table with all the rows on the nextgen plugin. How can I do?
    the function of the plugin ‘ Clear image cache’ does not solve the problem.

    Thanks for help.

    You are right, problem is widget.
    Temporary solution is crontab.

    $db = new mysqli('localhost', 'username', 'pass', 'dbname');
    $sql = "DELETE FROM <code>wp_options</code> WHERE <code>option_name</code> like '_transient_%' OR <code>option_name</code> like 'displayed_galleries%'";                                                                         
    if(!$result = $db->query($sql)){
        die('There was an error running the query [' . $db->error . ']');

    Hello All,

    I discover the same problems as this topic shows.
    But when i use the clear cache it works. Al the tables are going.

    How often will it be removed?

    And the script does not work. i made a script.php file with the code. Put it in to my cron and seem to give me an error all the time.

    Failed loading /usr/local/lib/ /usr/local/lib/ undefined symbol: zend_ce_closure Zend Guard Loader requires Zend Engine API version 220090626.
    The Zend Engine API version 220060519 which is installed, is outdated.

    There was an error running the query [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘wp_options WHERE option_name like ‘_transient_%’ OR <c’ at line 1]

    What is wrong?


    I did install again the latest Nextgen gallery.
    I do see the entries in the Database. But its not going that fast as before.

    I deleted the Widget ( Nextgen slideshow ) and put it back in again.

    I will look after a week what the plugin will do. Maybe this will help to solve some problems.


    Just been checking the plugin all day. And in the DB the labels displayed are cleared.

    So i say the update is working correct. And doeing what the developer made. Version 2.0.30




    Thanks everybody, had the same problem, I got a whitescreen of death because of this and was searching for an answer for hours now… Thanks RageLT for the command, I needed to deleted over 300,000 entries, more than 200MB… now my website is finally working again!

    Thanks so much for the info RageLT
    This has finally solved all my site issues, searched and found 240,000 ‘displayed_galleries%’ used the command to delete them all.
    Site now loads super quick again. Not getting any errors, no huge core dumps and high resource usage.
    Really stoked to finally sort what has been a huge problem #veryhappyface

    Is this bug back in the latest version? I have found installations with that problem (2.0.40). It seems that there will be created duplicate entries in wp_options table each time a gallerie is showed…..

Viewing 15 replies - 1 through 15 (of 38 total)
  • The topic ‘wp_options to many records’ is closed to new replies.