• Resolved dragonblogger

    (@dragonblogger)


    Ever since yesterday, been seeing these errors with the WP_Offload_Media plugin and my site crashing with errors.

    PHP Fatal error: Uncaught Error: Class ‘DeliciousBrains\WP_Offload_Media\Aws3\Symfony\Polyfill\Intl\Idn\Idn’ not found in /home/{sanitized}/public_html/wp-content/plugins/amazon-s3-and-cloudfront/vendor/Aws3/Symfony/Polyfill/IntlIdn/bootstrap.php:133
    Stack trace:
    #0 /home/{sanitized}/public_html/wp-content/plugins/amp/includes/class-amp-http.php(240): idn_to_utf8(‘www.{sanitized}…’, 0, 1)
    #1 /home/{sanitized}/public_html/wp-content/plugins/amp/includes/class-amp-http.php(205): AMP_HTTP::get_amp_cache_hosts()
    #2 /home/{sanitized}/public_html/wp-includes/class-wp-hook.php(289): AMP_HTTP::filter_allowed_redirect_hosts(Array)
    #3 /home/{sanitized}/public_html/wp-includes/plugin.php(206): WP_Hook->apply_filters(Array, Array)
    #4 /home/{sanitized}/public_html/wp-includes/pluggable.php(1480): apply_filters(‘allowed_redirec…’, Array, ‘www.{sanitized}…’)
    #5 /home/{sanitized}/public_html/wp-includes/functions.php(1905): wp_validate_redirect(‘https://www.{sanitized}…’, false)
    #6 /home/{sanitized}/public_html/wp-includes/pluggable.php(1139): wp_get_referer()
    #7 / in /home/{sanitized}/public_html/wp-content/plugins/amazon-s3-and-cloudfront/vendor/Aws3/Symfony/Polyfill/IntlIdn/bootstrap.php on line 133

Viewing 12 replies - 1 through 12 (of 12 total)
  • Same here, error after the latest update. I had to disable the plugin until the error is fixed.

    same with me… trouble with cloudfront ALIAS, disable this plugin until fixed or replace with another plugin

    Same error here since three days

    Same with Version 2.4.2. Version 2.4.1 was fine. Happened immediately on upgrade to 2.4.2.

    Fatal error: Uncaught Error: Class 'DeliciousBrains\WP_Offload_Media\Aws3\Symfony\Polyfill\Intl\Idn\Idn' not found
    in /var/www/[removed]/wp-content/plugins/amazon-s3-and-cloudfront/vendor/Aws3/Symfony/Polyfill/IntlIdn/bootstrap.php on line 133
    
    Call stack:
    
        idn_to_utf8()
        wp-content/plugins/amp/includes/class-amp-http.php:240
        AMP_HTTP::get_amp_cache_hosts()
        wp-content/plugins/amp/includes/class-amp-http.php:205
        AMP_HTTP::filter_allowed_redirect_hosts()
        wp-includes/class-wp-hook.php:289
        WP_Hook::apply_filters()
        wp-includes/plugin.php:206
        apply_filters()
        wp-includes/pluggable.php:1480
        wp_validate_redirect()
        wp-includes/functions.php:1905
        wp_get_referer()
        wp-admin/post.php:56
    Plugin Contributor ianmjones

    (@ianmjones)

    We’re aware of the problem and looking into it.

    https://github.com/deliciousbrains/wp-amazon-s3-and-cloudfront/issues/564

    Plugin Contributor ianmjones

    (@ianmjones)

    Fixed in 2.4.3.

    I’m still getting this when I edit a post. WP 5.5, WP Offload Media Lite 2.4.3. It happens on many admin actions actually, not just edit. Like plugin deactivation.

    Fatal error: Uncaught Error: Class 'DeliciousBrains\WP_Offload_Media\Aws3\Symfony\Polyfill\Intl\Idn\Idn' not found
    in /var/www/html/wp/wp-content/plugins/amazon-s3-and-cloudfront/vendor/Aws3/Symfony/Polyfill/IntlIdn/bootstrap.php on line 133
    
    Call stack:
    
        idn_to_utf8()
        wp-content/plugins/amp/includes/class-amp-http.php:240
        AMP_HTTP::get_amp_cache_hosts()
        wp-content/plugins/amp/includes/class-amp-http.php:205
        AMP_HTTP::filter_allowed_redirect_hosts()
        wp-includes/class-wp-hook.php:289
        WP_Hook::apply_filters()
        wp-includes/plugin.php:206
        apply_filters()
        wp-includes/pluggable.php:1480
        wp_validate_redirect()
        wp-includes/functions.php:1905
        wp_get_referer()
        wp-admin/post.php:56

    Hi, the error persist, even with the new update. It seems that there is a conflict with the AMP plugin. If i disable the AMP plugin, it work fine.

    Fatal error: Uncaught Error: Class 'DeliciousBrains\WP_Offload_Media\Aws3\Symfony\Polyfill\Intl\Idn\Idn' not found in /home/site/www/website1/wp-content/plugins/amazon-s3-and-cloudfront/vendor/Aws3/Symfony/Polyfill/IntlIdn/bootstrap.php:133 Stack trace: #0 /home/site/www/website1/wp-content/plugins/amp/includes/class-amp-http.php(240): idn_to_utf8('siteiawritin...', 0, 1) #1 /home/site/www/website1/wp-content/plugins/amp/includes/class-amp-http.php(205): AMP_HTTP::get_amp_cache_hosts() #2 /home/site/www/website1/wp-includes/class-wp-hook.php(289): AMP_HTTP::filter_allowed_redirect_hosts(Array) #3 /home/site/www/website1/wp-includes/plugin.php(206): WP_Hook->apply_filters(Array, Array) #4 /home/site/www/website1/wp-includes/pluggable.php(1480): apply_filters('allowed_redirec...', Array, 'siteiawritin...') #5 /home/site/www/website1/wp-includes/functions.php(1905): wp_validate_redirect('https://site...', false) #6 /home/site/www/site in /home/site/www/website1/wp-content/plugins/amazon-s3-and-cloudfront/vendor/Aws3/Symfony/Polyfill/IntlIdn/bootstrap.php on line 133

    Plugin Contributor ianmjones

    (@ianmjones)

    Yes, sorry about that, please revert to WP Offload Media 2.4.1, deactivate AMP, or enable the intl PHP extension.

    The problem is a little deeper than thought: https://github.com/aws/aws-sdk-php/issues/2092

    We’re looking into working around the problem in an upcoming bug fix release if we can’t get a fix pushed up to the AWS PHP SDK.​​​​​​

    Fixed in 2.4.3 but enable the

    • intl
    • PHP extension.

      Thanks for support

    I’m still seeing the issue with 2.4.3, and had to delete AMP manually after experiencing a “Critical Error” when I tried to deactivate.

    It would be less panic-inducing if the conflict could be handled in a more informative way.

    My host enabled the .intl PHP extension and media offloads are now working as required with no error messages.

    Plugin Contributor ianmjones

    (@ianmjones)

    Fixed in 2.4.4.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘WP_Offload_Media PHP Fatal Error’ is closed to new replies.