Support » Plugin: WP_Multilingual » [WP_Multilingual] language fallback to default language not working outside blog

  • Hi,

    Am hoping I can get in touch with someone who can help here. Previously I tried to post this on the WPML support forum but got an error message 🙁

    Thanks for your work on this great plug in.

    Am having a little problem that I cannot seem to find a solution for. Have searched this bug tracker but have not come across anyone with a similar problem. Indeed from there descriptions of how fallback to the default language works for them I have been convinced it is only me who suffers this problem??

    I have “Blog posts to display” set to “All posts (display translation if it exists or posts in default language otherwise).” On my web site http://cmhike.com

    But for posts in the default language with no translation I am not seeing them in either :

    * archives
    * recent posts
    * category pages

    Have got my home page using a custom static page and I don’t use the main blog page. The main blog page does display untranslated posts though in the default language as a fall back.

    Am using WPML 1.8.1.2 on WordPress 3.0.1

    Thanks for all your hard work!

    Jamie

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi all,

    In case someone else finds this post, it seems that the behaviour I describe above is normal. The fallback to default language only works on your blogs front page. The code used to get the fallback to work is pretty complex and though I’m a competent php programmer would take me some time to work out how to get the fallback working for other areas. Also since there seem to be a lot of sql queries involved in generating the fall back pages it may be very inefficient unless using a cache.

    Jamie

    Anyone had any experience with qtranslate do they implement default language fallback on untranslated pages for areas apart from the front page?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[WP_Multilingual] language fallback to default language not working outside blog’ is closed to new replies.