Support » Fixing WordPress » wp_list_pages maximum “more pages”

  • Hello,

    I am using WordPress for the first time with the Deep-Silent template. There I have a header-navigation bar with all the pages-links. I have added 7 pages which I want to show in my headers navigation bar. But once I add the 7th one WordPress adds an entry “More Pages” where it lists my just created page. I want to increase the maximum number of pages displayed but have no idea how.

    I tried to use the “numbers” parameter for wp_list_pages but this did not help. I also use the “Exclude Pages from Navigation” plugin since I do not want all pages to be listed there (could have done manually with excluding them I see).

    Is there any way to change this behaviour of WordPress and show my normal page rather than the “More Pages” ?

    Regards

Viewing 7 replies - 1 through 7 (of 7 total)
  • Do you have a link to the install so I can visualize what you are wanting?

    screenshot

    cant provide you with the actual blog as its private & password protected. But this should make clear what my problem is. “About” should not appear under More Pages but be at the position where More Pages is atm.

    some code in the theme’s functions.php looks like there might be some settings from your admin – appearance – ? for these ‘more pages’ links

    I do not really see any options to change the looks of the theme within the admin – appearance window. Can only activate/preview stuff there. And at the general settings I can not really find something either.

    You may have your ABOUT page set as a child to your MORE PAGES?
    Your ABOUT page should have no parent

    I neither have a “more pages” page nor does my “about” page has a parent. It is set to main page.

    It must be within the template somewhere, but I was yet unable to find the place where the maximum amount of pages is declared.

    Hi.
    I don’t know if you have solved this already or not (or which version of deep silent are you using)…but here’s a solution for 1.8 version:
    file you are looking for is script.js, you can find this in deep silent theme files.
    line 58: var lastlis = clearlis.slice(6);
    change the number (6) for whatever pleases you…7 in this case.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘wp_list_pages maximum “more pages”’ is closed to new replies.