Support » Fixing WordPress » wp_get_links stopped working when I upgraded to 2.1.3

  • Resolved ampersand


    I upgraded to 2.1.3 earlier today. For the most part the upgrade is great; however in my sidebar, where there had previously been lists of links sorted by link category, there is now nothing.

    Here’s the call I’m using, to list just one category at a time (which is necessary for my blog’s design):

    <li id="Alas-Related Links"><h2>Alas-Related Links</h2>
    <ul><?php wp_get_links(22); ?></ul>

    My blog can be viewed at . I’d appreciate any help or suggestions.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Try using the template tag, wp_list_bookmarks instead of wp_get_links.

    <?php wp_list_bookmarks('category=22'); ?>

    I just tried that, and thank you for the suggestion.

    But I’m afraid it didn’t change anything. 🙁

    I see your Atlas related links–what is wrong?

    I figured out what the problem was; for some reason, when I updated the version of WordPress, the numbers assigned to each category were changed. So writing

    <?php wp_list_bookmarks('category=22'); ?>

    Didn’t work because there no longer was a category #22; it had been renumbered and was now category 79. Once I noticed that the numbers had changed, and put in the correct numbers, then it worked fine.

    It happens because in 2.1 the post categories and link categories are merged in one single categories table, so they get renumbered…

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘wp_get_links stopped working when I upgraded to 2.1.3’ is closed to new replies.